Waveform library access

Ask any questions about using the new PicoScope 7 Automotive software here.
Post Reply
scott neal
OneWave
OneWave
Posts: 12
Joined: Mon May 03, 2010 10:47 am

Waveform library access

Post by scott neal »

Hi I’m unable to access the waveform library on my laptop, any ideas? In Pico 7 I get this message:
Waveform library path is missing or incorrect in the app.config file. Please configure key “WaveformLibraryApplicationPath With a full path to the waveform library executable including extension.
Also in Pico 6 as soon as I enter my log in it just kicks me out of Pico 6.
Any ideas?

Scott Neal

Steve Smith
Pico Staff Member
Pico Staff Member
Posts: 1356
Joined: Sun Aug 25, 2013 7:22 am

Re: Waveform library access

Post by Steve Smith »

Hi Scott, thank you for the post and sorry for any confusion here.

Could you refer to these posts viewtopic.php?p=103445#p103445 and here topic22981.html

You will need to update to the latest versions of PS7 here: https://www.picoauto.com/downloads

I hope this helps, take care.....Steve

scott neal
OneWave
OneWave
Posts: 12
Joined: Mon May 03, 2010 10:47 am

Re: Waveform library access

Post by scott neal »

Hi Steve,

I’m running the latest PS7 software. Is it a setting on my laptop I need to change that’s not allowing me to access it? I did read through the post but I’m still unsure what I need to do.
PS6 is no longer supported though so I take it this is the reason it kicks me out?

liviu2004
TwoWaves
TwoWaves
Posts: 434
Joined: Sat Mar 19, 2016 8:23 am
Location: Netherlands

Re: Waveform library access

Post by liviu2004 »

If you uninstall, reboot and install latest early access, does it make it working?
Not assuming anything, but is the 4425a connected to this pc?

scott neal
OneWave
OneWave
Posts: 12
Joined: Mon May 03, 2010 10:47 am

Re: Waveform library access

Post by scott neal »

I’ll give that a try. Scope is connected (4425).
I can open it on our home laptop. I installed ps7 on it last night. But not on my work laptop.

liviu2004
TwoWaves
TwoWaves
Posts: 434
Joined: Sat Mar 19, 2016 8:23 am
Location: Netherlands

Re: Waveform library access

Post by liviu2004 »

Which windows versions you run on each and type x32 x64? Have you installed and run as admin on work laptop?
Last edited by liviu2004 on Mon Aug 15, 2022 11:23 am, edited 1 time in total.

Steve Smith
Pico Staff Member
Pico Staff Member
Posts: 1356
Joined: Sun Aug 25, 2013 7:22 am

Re: Waveform library access

Post by Steve Smith »

Hi Scot and Liviu, thankyou for the posts and updates, have you been able to access the RWL?

scott neal
OneWave
OneWave
Posts: 12
Joined: Mon May 03, 2010 10:47 am

Re: Waveform library access

Post by scott neal »

Hi. The uninstall and reinstall seems to have done the trick. Thank you guys.

Post Reply