2009 BMW x5 E70 CAN bus trouble

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.
Post Reply
sky-chicken
Newbie
Posts: 4
Joined: Tue Jan 26, 2021 7:52 pm

2009 BMW x5 E70 CAN bus trouble

Post by sky-chicken »

My E70 X5 developed CAN trouble. When driving around the left headlight is flickering and the wipers go ip and down when lights turned on. When lights in driving mode with engel eyes on they move slowly to the middle. Sometimes the horn turns on for 1-3 minutes. Driving by night is impossible because of the flashing driver-side lights. I have to drive with engel eyes on only.
Sometimes the active suspension shows malfunction. I really don't know where to start the diagnostics on this car. Any advise?

liviu2004
TwoWaves
TwoWaves
Posts: 434
Joined: Sat Mar 19, 2016 8:23 am
Location: Netherlands

Re: 2009 BMW x5 E70 CAN bus trouble

Post by liviu2004 »

Do you have access to tools, diagnostic data, software and wiring diagrams?

sky-chicken
Newbie
Posts: 4
Joined: Tue Jan 26, 2021 7:52 pm

Re: 2009 BMW x5 E70 CAN bus trouble

Post by sky-chicken »

Yes, i have the latest ICOM FLEX and pico 4425. The problem is in the network CAAn wire for sure. The BMW E70 modules are well stowed away and i hate the idea to dissemble the car to find one cable. I was hoping someone had a similar issue and found where the CAN wire was defective. I think footwell module to next module because left lights, horn, wiper and active suspension is affected

ronw38
TwoWaves
TwoWaves
Posts: 61
Joined: Sun Aug 27, 2017 8:00 am

Re: 2009 BMW x5 E70 CAN bus trouble

Post by ronw38 »

Hi Sky chicken
You have answered Liviu's question re tools, wiring diagrams and basic diagnostic skills follow, silver bullet fixes are rare. Scan for com codes, pick an accessible module, scope can signals, being a BMW I would start in the trunk [water intrusion] check powers and grounds, activate the faulty circuits, monitor can signals, unplug modules to isolate the fault, 5 minute fixes are more rare than silver bullets. I wish I had the answer Cheers Ron W

Ggug12345
Newbie
Posts: 2
Joined: Sun Jul 10, 2022 7:22 pm

Re: 2009 BMW x5 E70 CAN bus trouble

Post by Ggug12345 »

I’m having the exact same issues with the lights, horn and slow motion/stopping windshield wipers on my 2010 bmw e70. I need to scan it but as you said I’m sure it’s prob a canbus issue somewhere. Did you ever find your issue?

sky-chicken
Newbie
Posts: 4
Joined: Tue Jan 26, 2021 7:52 pm

Re: 2009 BMW x5 E70 CAN bus trouble

Post by sky-chicken »

I did not but still looking. I removed most covers in the car and under the car. To find one wire in thousand miles of wiring seems to be crazy. When reseting and reading right after reset I did noticed that always the passenger side door contacts come up first in the error message. Have to find out how to check on those. Let me know what you find your issue. Be very careful when checking the ECM module connectors. I smoked my ECM when looking for the CNN wire issues and had to replace it.

AE86
Newbie
Posts: 1
Joined: Thu Jul 28, 2022 1:27 am

Re: 2009 BMW x5 E70 CAN bus trouble

Post by AE86 »

can线故障特点,1、干扰 2、对地短路 3、对电源短路 4、互短。
所以只有搞明白网络的拓扑图还有终端电阻,剩下的就是线路模块本身
最后即使是模块也要确定供电接地网络唤醒线,基本故障点就在这一块 :D


Translation:
Can line fault characteristics, 1. Interference 2. Short circuit to ground 3. Short circuit to power supply 4. Short to each other.
So only to understand the topology of the network and the terminal resistance, the rest is the line module itself
Finally, even the module has to determine the power supply grounding LAN wake-up line, the basic fault point is in this block :D

Ggug12345
Newbie
Posts: 2
Joined: Sun Jul 10, 2022 7:22 pm

Re: 2009 BMW x5 E70 CAN bus trouble

Post by Ggug12345 »

I have added an extra ground to the engine. Also removed and cleaned all grounds/contacts, changed out the FRM, fuse panel in passenger footwell along with its modules, headlight switch, windshield wiper assembly with motor and I’m sure I’m forgetting somethings. I did these one by one and when nothing changed I put my old parts back. The only thing that has changed is out of the blue my passenger side window decided to work. That was another mystery as all parts and switches affiliated with it were replaced with no fix. Has to be a canbus somewhere.

Post Reply