pico scope is only going in demo mode

Come here to introduce yourself, who you are, what you do, and tell us your
experience with our automotive products.
Post Reply
Posts: 1
Joined: Mon Oct 05, 2015 1:21 pm

pico scope is only going in demo mode

Post by islandtech »

hey Good day I've had my Pico scope for a few months now, but today I turn it on and noticed the usb red light is staying on solid and not blinking anymore, and the program is showing that am not connected to any device. I've tried downloading the program over again I've tried it on different computers and its still doing the same thing. now when I pulg it in I heard the connection being made but it only allowing me to go in demo mode

Steve Smith
Pico Staff Member
Pico Staff Member
Posts: 830
Joined: Sun Aug 25, 2013 7:22 am

Re: pico scope is only going in demo mode

Post by Steve Smith »

Hello and thank you for the post.

Can I ask if this symptom appeared before any updates?

Does your PC carry out scheduled updates overnight?

It would appear the PC can recognise a device connected to the USB socket given the "chime on connection"

Could you check in the Device Manager of your PC for your PicoScope (When connected)

Could you confirm your scope is powered by the Pico Blue USB lead and not an aftermarket USB lead or USB extension?

Could you confirm you also have the correct software in stalled?

PicoScope 6 if not using an automotive scope and PicoScope 6 Automotive if you are

I hope this helps, take care.......Steve

Post Reply