LIN decoding

Ask any questions about using PicoScope Automotive software here.
Post Reply
volrem
TwoWaves
TwoWaves
Posts: 232
Joined: Fri Jan 03, 2014 3:43 pm
Location: Estonia

LIN decoding

Post by volrem » Fri Jan 03, 2014 3:49 pm

Hi


I'm having trouble decoding LIN signal. I get error "Serial decoding failed - Not enough data".


Can somebody please have a look if i'm doing something wrong or is this function still too BETA.

According to manufacturer it is 9.6 kbit/s with LSB first.


Thanks
Attachments
2001 LIN-long.psdata
(1.25 MiB) Downloaded 254 times

User avatar
Fat Freddy
TwoWaves
TwoWaves
Posts: 314
Joined: Fri May 04, 2012 4:52 am

Re: LIN decoding

Post by Fat Freddy » Sun Jan 05, 2014 11:36 am

At a guess, I suspect sample rate is too low.
Crank it up and let us know how ya go.

HTH
FF

volrem
TwoWaves
TwoWaves
Posts: 232
Joined: Fri Jan 03, 2014 3:43 pm
Location: Estonia

Re: LIN decoding

Post by volrem » Mon Jan 06, 2014 6:33 am

Chosen sample rate was 2MS but actual (from properties) was 200kS/s.

So boosted up to 2GS (actual 80MS/s) but still not enough data.

LIN decoding says that it needs only 1,536 MS and next time said 7,679 kS.
Attachments
2001 V70 LIN2.psdata
80MS LIN capture
(2.03 MiB) Downloaded 254 times

Martyn
Pico Staff Member
Pico Staff Member
Posts: 259
Joined: Thu Aug 11, 2011 7:43 am
Location: Cambridgeshire

Re: LIN decoding

Post by Martyn » Tue Jan 07, 2014 11:29 am

We have looked at the captures and the data does not look like LIN packets which is why the software can't decode it. If you can give some more detail about where the data comes from we may be able to advise.

Alternatively contact support@picotech.com directly, we are working on a custom serial decoding feature that may enable you to decode this data.
Martyn
Technical Support Manager

volrem
TwoWaves
TwoWaves
Posts: 232
Joined: Fri Jan 03, 2014 3:43 pm
Location: Estonia

Re: LIN decoding

Post by volrem » Tue Jan 07, 2014 6:16 pm

Thanks for the reply.

It`s from 2001 Volvo V70 communication line between LSM (Light switch module), CPM (Combustion preheater module) and CEM (Central electronics module).

I`ll get more data from other lines/cars and then send info to e-mail.

volrem
TwoWaves
TwoWaves
Posts: 232
Joined: Fri Jan 03, 2014 3:43 pm
Location: Estonia

Re: LIN decoding

Post by volrem » Tue Jan 07, 2014 7:15 pm

Ok, did bit more digging.

Found that Volvo uses LIN starting from 2005 for most models and from 2004 for S40/V50.

Before that they had their own serial communicatin called "Volcano Lite".

So guess its solved for now. Although it would be nice to get decoding for this anyway.

Post Reply