Valeo Coil pack issues

Ask for and share advice on using the PicoScope kit to fix vehicles here.

Valeo Coil pack issues

Postby Avdr » Thu Aug 15, 2013 5:10 pm

Had a 2004 ford Ka in today, with EML and missfire under load. Code present was P0302. Swapped leads 2 & 3 round at the coil pack and fault followed the change to cyl 3 - P0303. Ordered a coil pack - a valeo unit, fitted it and drove the car again, perfect at first then within 500 yards there was a slight hesitiation even at moderate thottle openings. Quickly degraded into a total loss of one cylinder, and codes P0300 and P0301 now present.
Swapped back to the original coil pack, and was back to P0302.

Got in touch with supplier and get another coil pack sent out, again a valeo and a cheaper lemark alternative sent out too. Fitted the valeo, and instantly idle was 3 cylinder and generally rough.
Removed it and fitted the Lemark - perfection, extended test drive with plenty of uphill motorways slip roads in high gears, later and its still perfect.

Think valeo may have a bad batch out, worth pointing out I thought
Avdr
Guru
Guru
 
Posts: 156
Joined: Sun Jan 08, 2012 9:25 am

Re: Valeo Coil pack issues

Postby PicoPhil » Mon Sep 14, 2015 10:43 am

Hi
I think many manufacturers have coil issues and we all become aware of quality parts.
Philip
PicoPhil
Pico Staff Member
Pico Staff Member
 
Posts: 67
Joined: Thu Dec 23, 2010 11:38 am


Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests