Oxygen sensor ground connection

Ask any questions relating to the PicoScope hardware or kit contents here.
If you have any questions prior to purchasing the kit post them here.

what is it

Postby Autonerdz » Tue Dec 05, 2006 4:43 am

Looks like a negatively controlled saturated injector driver with the scaling wrong. Looks like a 20:1 attenuator is attached but PicoScope has not been told that it's there so the 14v circuit shows at .7v.

You will find the 20:1 selection under Settings/Probes. The way it is scaled from 0 to 1v (0 to 20) the injector kick is off the top of the screen. This is normally up to 80 volts. Select the 20:1 and then choose the +- 5v range to scale the screen to +-100 volts (with attenuator in place). Then you will see it all scaled correctly.
Tom Roberts
(The Picotologist)
Autonerdz
User avatar
Autonerdz
Zen Master
Zen Master
 
Posts: 272
Joined: Wed Nov 20, 2002 4:19 pm
Location: Washington State USA

Postby RobOnestop » Tue Dec 05, 2006 8:06 pm

believe it or not its what i got from a lambda sensor
Mobile Mechanic Specialising in
Auto diagnostics & Car Electrics
RobOnestop
Newbie
 
Posts: 5
Joined: Sat Nov 11, 2006 7:35 pm
Location: east sussex

strange

Postby Autonerdz » Tue Dec 05, 2006 11:26 pm

OK, you had me fooled. That's a classic injector pattern. You even have increasing voltage drop as the current rises. A bit noisy is all.

You need to increase the voltage scale and put some more time on the screen to get a few cycles in view and see the whole pattern. Could be some kind of pulsed O2 heater control. I don't have any info here on your application.
Tom Roberts
(The Picotologist)
Autonerdz
User avatar
Autonerdz
Zen Master
Zen Master
 
Posts: 272
Joined: Wed Nov 20, 2002 4:19 pm
Location: Washington State USA

Postby RobOnestop » Tue Dec 05, 2006 11:31 pm

ive not had pico long so still finding my feet
whats the best setting for zirconia lambdas time base
Mobile Mechanic Specialising in
Auto diagnostics & Car Electrics
RobOnestop
Newbie
 
Posts: 5
Joined: Sat Nov 11, 2006 7:35 pm
Location: east sussex

setup

Postby Autonerdz » Tue Dec 05, 2006 11:44 pm

You need lots of time on the screen to see the O2 cycles. Here is an example series at 1s/div:

http://www.autonerdz.com/cgi/yabb2/YaBB ... 1114921447

These are standard Zirconia sensors pre and post CAT.
Tom Roberts
(The Picotologist)
Autonerdz
User avatar
Autonerdz
Zen Master
Zen Master
 
Posts: 272
Joined: Wed Nov 20, 2002 4:19 pm
Location: Washington State USA

Previous

Return to Automotive kit hardware

Who is online

Users browsing this forum: No registered users and 1 guest