VW Golf 2005 - PD BKD Engine

Ask for and share advice on using the PicoScope kit to fix vehicles here.

Re: VW Golf 2005 - PD BKD Engine

Postby STC » Tue Jul 18, 2017 9:28 am

Do you think it could be caused by someone that messed with the software maps?

That is entirely possible. As I wrote in my initial post, EGR has been Blanked and mapped out. The EGR Diaphragm does not hold vacuum.

For sure the ECU has been out before, missing bolts, connector covers ....

For all I know it could well be the wrong ECU in the car.
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: VW Golf 2005 - PD BKD Engine

Postby KimAndersen » Tue Jul 18, 2017 2:28 pm

Hi STC

I may be able to contribute with some info regarding the scaling of this map sensor - which have the same Bosch part number 038 906 051 C as a VW JETTA TDI 2.0 (BMM) 103kW that I took a picoscope reading of.

I know the engines are not completely identical but the Map sensors are and from this picture below I´ve all the information to make a complete linear curve which later on can be used to interprete the output voltage versus the pressure we are getting.

MAP_SENSOR_038906051C.jpg
MAP SENSOR 038 906 051 C


You mentioned that, the specified output voltage from this sensor is between 1.4 to 1.8 volt at idle speed which correspond to 86.38 kPa and 112.67 kPa based of the curve that I made.

BOSCH MAP SENSOR  # 038 906 051 C.png
MAP SENSOR CURVE #038 906 051 C


When I compare your reading with my readings from the Jetta TDI I´ve got around 100 kPa at idle speed which correspond with 1.6 volt which is right between the tolerance that you described earlyer on - so its not that way off in regard to the specfications !

The pressure reading you got at KOEO is outside the specification and could be someone had been doing some remapping, but it could also be a effect off the changes that are made to the EGR system - I think !.

Regards
Kim :wink:
KimAndersen
TwoWaves
TwoWaves
 
Posts: 184
Joined: Fri Nov 30, 2012 4:53 pm
Location: Denmark

Re: VW Golf 2005 - PD BKD Engine

Postby Fat Freddy » Tue Jul 18, 2017 3:05 pm

This throws a Manifold / Boost Pressure Sensor Signal Implausible fault at Ignition on. Won't Clear.

Engine not running I see 1306mB in measured values against 1020 mB atmospheric and desired. The Fault Code is accurate and Validated.

Bosch ESi (this is a Bosch ECU and Component) specifies MAP Voltage to be at 1.4 to 1.8v at Ignition On and at idle - Yes same figures ?? I guess it won't be boosting at idle ?? I have 1.4v with 3 Boost pressure sensors - Original, Customer replacement and Mine from the dealer ( Sealed Package )

But.

Used Sensor Simulator to manipulate values below and above "Desired" ECU reaction is confirmed as Good. Dial it to match atmospheric and the Fault Clears.

And at what voltage was that?

1.4 Volts Confirmed with PP3 and Fluke 123 Scope - and stable, not an average.
Not fluctuating either. Confirmed!

Just to clarify. Is the ECU happy with 1.4V being simulated but not 1.4V when it's from the sensor?
I may be getting confused. :?
User avatar
Fat Freddy
TwoWaves
TwoWaves
 
Posts: 310
Joined: Fri May 04, 2012 6:52 am

Re: VW Golf 2005 - PD BKD Engine

Postby STC » Tue Jul 18, 2017 11:40 pm

Freddie
Just to clarify. Is the ECU happy with 1.4V being simulated but not 1.4V when it's from the sensor?
I may be getting confused. :?


That would be a typo. I am working from memory now. I believe 1.6v is what the sensor output was and 1.4v was what I dialled in to get Measured Values to match atmospheric - circa 1020mB. The correction / drift factor was 200 -250 mV. I did not check to see if that was maintained further up the range or if it compounded.

Kim
The pressure reading you got at KOEO is outside the specification and could be someone had been doing some remapping, but it could also be a effect off the changes that are made to the EGR system - I think !.


Thank you, some good info in your post, I am thinking along the same lines..

There has been progress, I managed to get my hands on a second hand ECU today. With it plugged in the Measured MAP values are spot on :) Using a Mityvac they are accurate across its working range.

Of course the engine wont start - Immobilised, and if it did I expect EGR errors.

Fingers crossed, some mapping and manipulation and I can announce a fix.

I can get a Flash & EEprom reading from the faulty ECU if anyone wants to analyse it to determine if this was a Software or Hardware error - just ask.
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: VW Golf 2005 - PD BKD Engine

Postby dieseljohnny » Wed Jul 19, 2017 9:26 pm

Hi STC

Send me on the Flash if you have it handy and Ill have a look at the MAP sensor calibration
dieseljohnny
OneWave
OneWave
 
Posts: 26
Joined: Mon Oct 12, 2015 11:08 pm

Re: VW Golf 2005 - PD BKD Engine

Postby STC » Wed Jul 19, 2017 9:29 pm

Send me on the Flash if you have it handy and Ill have a look at the MAP sensor calibration


PM me your email please.

thanks
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Previous

Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests