Skoda Octavia 2,0 TDI CR 2011 CFHC P0641 - Fixed

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

Re: Skoda Octavia 2,0 TDI CR 2011 CFHC P0641

Postby Martinjensen » Sat Apr 08, 2017 5:37 pm

Progress has been made. :-)

I newer thought of measuring for contiunity on the ECU to establish what sensors internalley shares the different 5V feeds. Thanks for that STC. But the biggest problem was before the car acted up, i only have the regulator A fault code, and with no documentation of what componemts connected to it, there were multiple components that would cause that.

I also would like far more channels on my scope. :-)

I first chose to moniter the feed for CMP, MAP, DPFE sensor, and EGR, CKP, RPS, Trottle body, and Turbo position sensor, this could be done with 4 channels, but the 2 feeds for APP 1 and 2 could not be measured at the same time.

When the car finalley acted up, there was a drop in the feed for CMP and DPFE, but what about APP 1 and 2??

Ok i now hawe 3 channels left over for further tests.

I desided to still measure the feed for the DPFE, the feed for both APP sensors, and added an amp clamp to the DPFE sensor.

Took the car for several drives, and suddentley right after turning the ignition on, there was an exessive Draw from the DPFE sensor, and the engine ECU flagged the code Again.

Later on the test drive the amp Draw from the sensor suddeltley spiked up for a short while, but not enough to set a code.

So it seems that Regulator A feeds CMP APP 1 and DPFE

Blue trace: DPFE Current
Red trace: APP2 feed
Green trace : APP1 feed
Yellow trace: DPFE feed
Attachments
G505.PNG
Amp spike
Fault present.PNG
Exessive amp draw
Amp clamp.PNG
Clamp placement
P0641 - Bad DPFE sensor 1.psdata
Amp spike
(2.04 MiB) Downloaded 40 times
P0641 - Bad DPFE sensor.psdata
Exessive amp draw
(1.62 MiB) Downloaded 24 times
Martinjensen
OneWave
OneWave
 
Posts: 36
Joined: Wed Feb 13, 2013 8:22 pm
Location: Denmark

Re: Skoda Octavia 2,0 TDI CR 2011 CFHC P0641

Postby STC » Sat Apr 08, 2017 10:41 pm

Later on the test drive the amp Draw from the sensor suddenly spiked up for a short while, but not enough to set a code.


So it seems that Regulator A feeds CMP APP 1 and DPFE


Martin
From what I have read and understood is that your DPF sensor is at fault - Internally Shorted ? - Is that correct ?
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: Skoda Octavia 2,0 TDI CR 2011 CFHC P0641

Postby Martinjensen » Sun Apr 09, 2017 11:05 am

From what I have read and understood is that your DPF sensor is at fault - Internally Shorted ? - Is that correct ?


Yes that is my conclusion based upon clamp placement, tomorrow i will fit a new genuine pressure sensor.
Martinjensen
OneWave
OneWave
 
Posts: 36
Joined: Wed Feb 13, 2013 8:22 pm
Location: Denmark

Re: Skoda Octavia 2,0 TDI CR 2011 CFHC P0641

Postby STC » Mon Apr 10, 2017 12:13 am

Well done I think you have it. Please be sure to report back the conclusion to this.

Thank You
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: Skoda Octavia 2,0 TDI CR 2011 CFHC P0641 - Fixed

Postby Martinjensen » Wed May 03, 2017 10:01 am

The car has been driven by the customer for almost a month now with no issues.

I replaced the dpf sensor that was intermittently shorting out internalley, with a new genuine part.

The new sensor consumes approximately 20mA on the feed wire.

Thanks to Richard and STC for your input and great ideas.

Regards Martin.
Martinjensen
OneWave
OneWave
 
Posts: 36
Joined: Wed Feb 13, 2013 8:22 pm
Location: Denmark

Previous

Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 0 guests