BMW E92 2009

Ask for and share advice on using the PicoScope kit to fix vehicles here.

Re: BMW E92 2009

Postby STC » Fri Sep 23, 2016 6:18 pm

RS
Just before you put a new injector on it would be an idea to confirm that it isn't commanded to do that. An amp clamp will give you that in 2 minutes.

I had a Audi RS6 some years ago that would throw / spray petrol out of the exhaust (cats cold) about 2 metres, that was the ground side switched wire short to ground holding the injector open.

Low compression could just be bore wash but I see 2 cylinders low ??

Your primary is still looking messy. It just came to mind that BMW do fire the Coils 3-4 times with the piston on power stroke only at idle, have seen it myself. Think they call it Multi Strike ? Could be wrong.
Last edited by STC on Thu Sep 29, 2016 11:28 am, edited 1 time in total.
User avatar
STC
Zen Master
Zen Master
 
Posts: 369
Joined: Sun Sep 13, 2015 2:10 am

Re: BMW E92 2009

Postby PicoKev » Fri Sep 23, 2016 9:11 pm

STC wrote:Think they call it Multi Strike ? Could be wrong.


Well Ford in the US certainly have done for several years!

It is spreading to numerous manufacturers nowadays especially as a start-up strategy. BMW is certainly using it in several market areas.

If anyone has several hours to spend on PD then "Google & Go". :lol: A reasonable starting point can be found here :arrow: http://dtec.net.au/Multi%20Spark%20Ignition.htm

Kev.
PicoKev
User
User
 
Posts: 39
Joined: Thu Apr 05, 2012 9:16 am

Re: BMW E92 2009

Postby victor2k » Sat Sep 24, 2016 7:04 am

RS-4 wrote:Hi guys


Here I am again. I'm still fight with BMW. Mounted the new coils and spark plugs but without success...


Then I made a test injectors and finally ...


As soon as I mounted the new injector I will continue with waveforms.


I also saw that compression is not good but we'll see how it will work with the new injector.

Try to record injectors curent(at the ECU side) and maybe you will see something like a shorted coil of injector.
You can't see any trouble monitoring primary voltage in this case
Attachments
Untitled.png
victor2k
Advanced User
Advanced User
 
Posts: 79
Joined: Thu Jan 28, 2016 7:17 am

Re: BMW E92 2009

Postby RS-4 » Tue Sep 27, 2016 9:21 pm

Hello
just to say I am now finished with BMW. I am replacing the injector cyl.1, all COP and spark plugs. The engine works quite well but I noticed that the mixture is still rich in bank 1. STFT came down from -25 to -5 and here are stuck and lambda is to highly, that's why I gave the car owner to drive a few days.

I recorded waveforms of injector no.1, primary and secondary ... see that COP transferred from Multi spark system to the ordinary spark system ... why ... I don't know.
Also injector waveform is not well known to me. The direct injection system has a strange injector waveform.
Unfortunately, many waveforms from this car is confuse for me.


Thank you all for advice and assistance.

Regards
Attachments
IMG_20160926_101013691.jpg
VID_20160927_150241321.mp4
(22.74 MiB) Downloaded 11 times
All coil + primary cyl.1 1MS.psdata
All coil + primary cyl.1
(1.07 MiB) Downloaded 11 times
cop orange.psdata
Secundary cyl1
(3.88 MiB) Downloaded 13 times
Injector cyl.1-ok.psdata
Injector cyl.1 curent+voltage
(1.18 MiB) Downloaded 16 times
IMG_20160926_153816078.jpg
mixture
RS-4
User
User
 
Posts: 13
Joined: Sun Jun 20, 2010 10:10 am

Re: BMW E92 2009

Postby STC » Wed Sep 28, 2016 12:45 pm

Change the Oil & Filter - the sump will be full of HC's
User avatar
STC
Zen Master
Zen Master
 
Posts: 369
Joined: Sun Sep 13, 2015 2:10 am

Re: BMW E92 2009

Postby RS-4 » Wed Sep 28, 2016 3:23 pm

Hei,

I did that the oil level was 73mm and after replacement 67mm.

Thanks for the advice
Attachments
IMG_20160926_110756296.jpg
RS-4
User
User
 
Posts: 13
Joined: Sun Jun 20, 2010 10:10 am

Re: BMW E92 2009

Postby STC » Wed Sep 28, 2016 9:29 pm

Hi RS 4
We get lost with translation sometimes.

You changed the Oil and Filter?
Did that fix the Fuel trims ?

And that fault code, was that due to the Petrol Diluted Oil ?

that COP transferred from Multi spark system to the ordinary spark system ... why ... I don't know.


I would guess that it warmed up, Multispark tends only to be used for cold start up and then only at idle. I would imagine that there would not be enough time to re charge the coils at higher RPM's
User avatar
STC
Zen Master
Zen Master
 
Posts: 369
Joined: Sun Sep 13, 2015 2:10 am

Previous

Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests