Passat 1,9 PD TDI bad noise

Ask for and share advice on using the PicoScope kit to fix vehicles here.

Passat 1,9 PD TDI bad noise

Postby csasziszerviz » Fri Nov 13, 2015 7:09 am

Hi,

I have a problem with this car engine. The engine code is BKC, this is 1,9 PD TDI engine.

The problem is the next. The owner make a leak to the oil pan last month. They tried to change the oil pan, but they broke the crankshaft seal, and it have to be changed. This engine have the crankshaft position sensor in this seal. They changed it, but the car is not working well. Sometimes the engine have power and not give big smoke, but if I press accelerator pedal about 20-30 %, the engine have a bad (very bad) noise, give a big black smoke, and loss power.

I have tried to check everything, but I don't know what is the real problem. As I think, the turbo pressure is good (It canged about 500 km before), and the injectors are good.

One thing, what I saw when I drove the car with tester is the preload value problem. When I drive without press the accelerator pedal everything good. After press it, the preload value goes up, but when the car starts to give bad noise, it is goes to 0. I think the car havent't got good position mark and don't know what value is good for preload.

I think something happened, when they changed the crankshaft seal, and it is not give real position mark from the crankshaft. As I know good, the car compensating a bit, but the crankshaft mark have to be exact.

I measured the crankshaft and chamshaft mark with Pico, and attached the measuring.
I would like to ask you, somebody look this. This is good waveform? Have somebody car with same type enginge? If yes, please measure what I, to reference measuring.

I would like to try measuring with WPS sensor to search the real TDC. For example ch.A will be crankshaft position sensor, ch.B the WPS, and ch.C is the injector voltage or something reference.
Have anybody information about the sensor's mark? When I see the pico screen, where have to be the real TDC in crankshaft position sensor mark?

The car worked well before the part changed, but unfortunately this is not 100%, because the owner sad this ... :D
Sorry, my english is not the best, but I hope you understand what I would like to write.

Thanks the help
Attachments
PASSAT_ BKC_19PDTDICAM-CRANKSNSR.psdata
(1.71 MiB) Downloaded 94 times
csasziszerviz
User
User
 
Posts: 10
Joined: Sun Dec 14, 2014 1:11 pm

Re: Passat 1,9 PD TDI bad noise

Postby Robski » Fri Nov 13, 2015 1:37 pm

Torsion value ?

Ask previous repairer if they used the correct tool for the rear oil seal/reluctor fitment along with CKP timing tool ?
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Passat 1,9 PD TDI bad noise

Postby csasziszerviz » Sat Nov 14, 2015 7:50 am

Hi,

I don't rememer to the torsion value, I will check it on monday.

I asked them, and they told me, thely used corect original tool for seal, but they lock only the chamshaft with the locking pin. I think, that cause the problem, because if the timing belt is old a bit and the tensioner is not the best, crankshaft was not in the exact position. They should have to use the crankshaft locking tool, but they didn't do that unfortunately... :(
That's why I woult like to measure the real TDC with WPS sensor and check the position sensor mark in one measure, but I need a reference waveform for pressure diagram plus crankshaft position sensor mark.

Have a nice day!
csasziszerviz
User
User
 
Posts: 10
Joined: Sun Dec 14, 2014 1:11 pm


Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests