Waveform channel swapping

Ask any questions about using PicoScope Automotive software here.

Waveform channel swapping

Postby Steve Smith » Thu Aug 07, 2014 1:14 pm

Many thanks to all the Pico users who have reported a sporadic and very odd glitch within the PicoScope 6 Automotive software prior to version 6.9.14 (Current stable version)

When downloading new software from the Pico Website you will often find the "release notes" or a brief overview of the updates and bug fixes contained within the latest release.

Currently you can see "Captured data can become swapped between channels on some 4000 series devices"

To elaborate a little on this symptom, you may find when using 3 or 4 channels that the input signal changes channel!

Eg. Cam and crank signals on Channels A and B, injection and ignition on Channels C and D. Whilst capturing the data and monitoring the waveform on screen, Channel C and D may swap input signals midway through a screen capture.

There are occasions when Channel C correctly displays an injection event for the first half of the screen and an ignition event for the remainder of the screen (on the same channel)

The symptom can be very difficult to reproduce given it does not effect all devices and is only ever apparent intermittently when 3 or more channels are active.

This issue was identified immediately after build and within 5 days the symptom was diagnosed, software built, internally tested and released to the website.

Please be aware that if you do experience this issue, downloading the latest software version 6.9.14 or later will resolve the concerns above

I hope this information helps and once again thank you for the feedback and patience on this nuisance issue

Take care.......Steve
Steve Smith
Pico Staff Member
Pico Staff Member
 
Posts: 442
Joined: Sun Aug 25, 2013 7:22 am

Re: Waveform channel swapping

Postby Robski » Thu Aug 07, 2014 10:41 pm

cheers Steve..................if only I had seen this before this morning :shock:
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Waveform channel swapping

Postby Steve Smith » Fri Aug 08, 2014 10:38 am

Hello Rob, a lesson learned by me for sure.(Thanks for the heads up too)

Apologises to all who experienced this issue as it had me over too.

Take care......Steve
Steve Smith
Pico Staff Member
Pico Staff Member
 
Posts: 442
Joined: Sun Aug 25, 2013 7:22 am

Re: Waveform channel swapping

Postby Robski » Fri Aug 08, 2014 6:37 pm

yes it certainly slipped me a crippler ! Back to normal now though.
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire


Return to PicoScope 6 Automotive software

Who is online

Users browsing this forum: No registered users and 5 guests