Cummins 6.7L Exhaust Brake Engaging When Accelerating

Ask for and share advice on using the PicoScope kit to fix Heavy Duty and Off Highway machinery here
RyanH
OneWave
OneWave
Posts: 24
Joined: Sun May 02, 2010 12:38 am

Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by RyanH »

2006 Dodge Ram 3500 6.7L

Issue:

This truck has had this issue for for several years. When accelerating above 50% throttle the exhaust brake slams on and will not release until the engine is returned to an idle for several seconds. The VGT position before accelerating is around 54%, matching the desired value. When you accelerate, the desired value increase to 74% but the actual pins the VGT closed at 94%. Also when coasting with the exhaust brake switched on, it will not release either until brought back to idle.

History:

A complete turbocharger with actuator was installed last week by the customer. After the install the issue became more frequent. I inspected the old turbo and found the VGT stuck in the open position. I then removed the actuator on the truck and verified the VGT moves freely by hand from open to close. I recalibrated a new actuator to the turbo but the issue remains. The CAN network is 100% when the issue occurs. I scoped the network with my Pico and added a A-B math channel and decoded. No lost data. Power and grounds are good but the current is high when the VGT is stuck closed. I don't have a way of verifying which direction the VGT actuator is applying this current. The truck is deleted but I returned it to the stock programing with no change. The exhaust back pressure sensor reads normal and the issue occurs with it unplugged. The problem does not occur with the VGT actuator unplugged as suspected. I don't see any glitches in the accelerator pedal position sensors either.

Has anyone seen this issue before? Also any ideas on other inputs that I may look at. I feel that this is a command issue and not a turbo problem. This is a manual transmission Cab and Chassis truck as well if that makes any difference.

Thanks for taking the time to read my post.

liviu2004
TwoWaves
TwoWaves
Posts: 470
Joined: Sat Mar 19, 2016 8:23 am
Location: Netherlands

Re: Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by liviu2004 »

No sane designer will make possible for canbus to be loaded 100% . NO SINGLE ONE.

RyanH
OneWave
OneWave
Posts: 24
Joined: Sun May 02, 2010 12:38 am

Re: Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by RyanH »

Sorry, to clarify the CAN bus 'looks' 100% as in it looks good with no issue. Its not transmitting at 100% capacity.

PaulW
OneWave
OneWave
Posts: 18
Joined: Tue Jul 26, 2022 5:37 pm

Re: Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by PaulW »

Hello Ryan,
I work on Heavy and Medium duty trucks at a Truck dealership. I am not aware of what software dodge uses for their Cummins. I do not have much experience on scan tools. When I have a driveability concern like this, I use a PID with Cummins Insite that monitors Engine Operating State: it will show if throttle is depressed, cruise control, PTO, transmission torque derate, the list goes on. I'm not sure what a scan-tool PID would be calling this, or if there is one? The other engine manufacturer I work on does not have this PID, and that makes it more time-consuming to diagnose. When I have a weird cut out like this and not sure of what the engine is doing, I will look this PID up and watch when the issue occurs. I then know there is an input into the ECM causing this. This helps keep me from going into numerous rabbit holes. Insite will not communicate with Dodge's Cummins engines. Hopefully you can find something like this. Do you think it could be an ABS wheel speed sensor intermittently cutting power?

RyanH
OneWave
OneWave
Posts: 24
Joined: Sun May 02, 2010 12:38 am

Re: Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by RyanH »

I will take a look at the PIDs tomorrow. I know there is an engine state PID but if I recall correctly it had more to do with the exhaust aftertreatment such as DeSoot or regen but I may be wrong.

Good point again about the ABS. I did have an older Cummins have power issues with a shorted ABS wire. In this application though the exhaust brake kicks out below 5 mph. Worth looking into.

Thanks.

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 534
Joined: Tue May 16, 2017 1:02 pm

Re: Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by ben.martins »

Hi Ryan,

Sounds like an interesting one for sure and as you say certainly sounds like command due to something else.

ABS is an interesting one and does need some attention. If the throttle doesn't go above 50% can you drive the truck?

Forgive my naivety when it comes to different truck models but what are the conditions for the exhaust brake to be active? Could EGR be having an effect where the ECU is seeing incorrect MAF readings, unmetered air, by a partially stuck EGR?

Lots to consider especially as this has been ongoing for over a year.

Keep us posted and we'll continue to think about what else you could be looking at.

Kind regards

Ben

RyanH
OneWave
OneWave
Posts: 24
Joined: Sun May 02, 2010 12:38 am

Re: Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by RyanH »

Hi Ben,

Yes, if you drive the truck under 50% throttle you can, very slowly, accelerate through the RPM range. To me it appears to be the sudden demand for acceleration that commands the VGT to 74% to spool the turbocharger up but the actual continues on to 94% closed which is the exhaust brake range.

For the VGT to close to more than 90% there are two scenarios. First, no accelerator pedal input, no vehicle speed, exhaust brake switch active, engine coolant temperature below a specific value, possibly the park brake engaged and the transmission in park or neutral. This is for engine warm up and does function correctly. Pressing the exhaust brake button does command the brake on and off as it should.

The second is the exhaust brake. The vehicle speed needs to be above 8 km/h, exhaust brake switch active, no accelerator pedal input, and zero fuel delivery. My issue is occurring with three of the four inputs not in the correct state. I have fuel delivery, the exhaust brake switch is off and there is pedal input.

I could see one input having an issue but not all three.

RyanH
OneWave
OneWave
Posts: 24
Joined: Sun May 02, 2010 12:38 am

Re: Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by RyanH »

Just to update on this truck. It appears when it was deleted the stock exhaust was just drilled out. I did pull the down pipe off at the turbocharger and drove it again but the issue was still there. The exhaust back pressure is reaching 66 psi above atmospheric pressure when the brake is coming on. At this point the two options I have given the customer are to reprogram the ECM with the Chrysler software instead of the RaceME or to replaced the ECM. I am heavily leaning towards the ECM itself at this point.

Here are the issues I am running into. First, a new ECM is more than the customer wants to spend. From my local dealership I believe is retails around $6500 CND. Second, I am not set up to program Chrysler products at this time. I will need to correct this issue in the near future but even worse the Dealer says they don't have the equipment any more to program it either. From talking to another diesel shop south of the border, it appears that a used ECM could be reprogrammed to this vehicle if the hardware matches. Does anyone have any insight into this? We are not that small of a city but there is only one shop that is set up to program Chrysler vehicles and they don't think it is possible.

The only option left is a reman unit from one of the online retailers. I believe this may be the route the customer will go. I will follow up when the repair is complete.

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 534
Joined: Tue May 16, 2017 1:02 pm

Re: Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by ben.martins »

Hi Ryan,

Sorry for the late reply on this.

It sounds like this is going to be one of those jobs! I think we've got to try and get it back to stock software. There are too many variables going on that can be affecting the input. Would be interesting to know if these issues have been there since the delete.

I'm afraid I can't help with the reprogramming side of things. Hopefully someone else on the forum might be able to offer an insight. Given the cost, a reprogram would be a sensible approach. Would a new ECU come preconfigured or would you need to program it once it arrives? Either way, shocking to hear that dealership can't help you either with this.

Do keep us posted Ryan. It'll make an interesting case study for certain!

Kind regards

Ben

RyanH
OneWave
OneWave
Posts: 24
Joined: Sun May 02, 2010 12:38 am

Re: Cummins 6.7L Exhaust Brake Engaging When Accelerating

Post by RyanH »

If I was able to reprogram in house, I would definitely give it a try. At this point the only option in our city would cost roughly $580 to flash the ECM with the Chrysler software. The customer is opting for a reman ECM that comes pre-calibrated.

This issue started serval years after the delete so I don't think it is related but without reprograming I could not rules this out 100%.

I am looking into the hardware for myself to cover any holes we have in ECM programing. I will let everyone know the result one the ECM is in.

Post Reply