Discovery intermittent EML

Everyone loves a happy ending. Share your diagnostic success stories here.
Post Reply
dosdawson
Newbie
Posts: 8
Joined: Mon Jun 23, 2014 10:59 am

Discovery intermittent EML

Post by dosdawson »

How long between occurrences of a fault before its called an intermittent fault?? 15 minutes? an hour? A week perhaps? What about a month between occurrences?? Well that's definitely intermittent and that's what i was faced with when i was given a job with an EML on and intermittent lack of power.
The vehicle was a Landrover Discovery 4 3.0 l v6 diesel. Nothing out of the ordinary at first, but i was told by the workshop controller the vehicle had been in the previous month and the month before that, for the same fault!
The first visit the turbo had been replaced. If your not familiar with these vehicles and engines to replace the turbo is a big job, where the body is removed to make access to turbo easier. I have been told its possible to replace turbo with body on but it doesn't look like a very nice job! So the body had been removed on first visit. The second visit the wiring for the turbo was found routed incorrectly and it was suspected to be causing the fault.
So first thing to do was connect SDD and carry out code read
DTC list.png
As you can see the vehicle had a full set of turbo codes!
One very good feature of SDD is the ability to see the frequency of dtc's occurrences. This showed the fault had occurred 3 times over 150 drive cycles, very intermittent then !!
I decided to start with the basics and carried out an inspection of engine and smoke test of intake system. I also inspected turbo connector ( easier said than done !).All of which showed nothing obvious. Looking at the codes it doesn't suggest air leaks but better to check all this now than 5 hours into the job ! Also I don't know what has been checked before. At this stage I'm also presuming this is the original fault and not one that's been added when turbo fitted.
To be honest I'm now struggling a bit for my next move with a fault this intermittent! So I decided to chance it and road test in an attempt to get it to fault. I connected SDD and ran data logger with turbo actuator desired and measured positions then headed out.
It took twenty minutes but it faulted ! EML on with restricted performance. Quick glance at SDD showed turbo measured position flat lined at 54.6%, but desired position was still fluctuating with throttle demand.
DATA LOGGER.png
Back to workshop, turned engine off and on, fault gone! I rescanned fault codes and all the turbo codes had returned. I cleared them again but could not get it to fault again .
Time to step back and recap. Next time it faults I need to be ready!
So here's what I know:
1.Turbo position was flat lined at 54.6% (fault occurring )
2.ECU was attempting to alter position.
3.IGN cycle clears fault.
Here's what I'm thinking: Turbo position flat lined at 54.6% then stays there until IGN cycle, surely position circuit is good or there would be some fluctuation as turbo would still be moving ?? Then what about the actuator circuit, again surely there would be some fluctuation in position if the actuator was faulty or the wiring was open/short intermittently, added to that the IGN cycle clears the fault?? This leaves the engine ECU ??? A lot of ifs and buts ! I need to prove its the ECU before throwing one at it, so It was time to get creative!
What I decided to do was measure the PWM at the turbo and to rule out wiring issues measure the PWM out of the ECU at the same time. Connecting scope to ECU was easy enough but connecting it at turbo was anything but! Its buried deep so I got creative and made up a break out lead to connect to turbo connector and then run inside the vehicle.
break out lead connections.png
break lead connected.png
break out lead routing.png
I connected scope to these points and then tested it.
Scope connections.png
Here's what I got .
turbo test.png
This is zoomed in.
turbo test zoomed.png
The breakout lead worked so I headed out on road test feeling pretty chuffed with myself :lol: .
My smugness slowly faded over the next hour as I realised the fault wasn't going to occur again ! :|
More road testing over the next week was also futile, until I had to concede and the vehicle was giving back to customer. Gutted, I thought I was onto something but in the end it was out of my hands!

Fast forward 4 months, 2 of them locked down as house husband, had help me forget about this troublesome discovery. After 2 weeks back at work I was given a Discovery with EML on and told it had been in a month ago and had a throttle housing fitted but EML was now back on. Nothing unusual so far ! I read DTC'S and found a full set of turbo codes!!! Hmmmm this isn't that discovery I was struggling with a while back is it??? Quick check of the history and it is!! But why has it had a throttle housing fitted on the last visit? Looking at the last job card the tech had found P0234-77 stored ( along with the full set of turbo codes ) which on its own suggests a known fault and bulletin for new throttle housing. But with all of the turbo codes it doesn't !!
I reconnected my break out lead connected the scope and also ran SDD with data logger showing turbo position and desired position then headed out for road test. It took 10 mins and it faulted !!
Fault occurring.png
The Ign was turned off at around 18 seconds.
Ign off then on.png
The Ign is off then turned on just after 5 seconds.

Looking at SDD the turbo was flat lined again but this time at 35.3% ( different to last time ). The PWM to the turbo was missing and was also missing at ECU !! Result!! :D smugness back !!
Before I condemned the ECU I checked that all lives and earths were good whilst faulting. Luckily the fault was now occurring on cue. It was now June and it was quite hot so I suspect the heat was effecting the ECU. I have seen this before and have used a heat gun to reproduce faults in the past. The fact the fault is now occurring more frequently is good news to confirm fault is fixed once I fit the new ECU, or I would be waiting a month to find out! A new ECU was fitted and retested with no problems.
The vehicle has been back with customer now for 6 months with no reoccurrence of the fault.

Steve Smith
Pico Staff Member
Pico Staff Member
Posts: 1025
Joined: Sun Aug 25, 2013 7:22 am

Re: Discovery intermittent EML

Post by Steve Smith »

Hello and thank you for the post and insight into a real tough call (New ECU)

I know how long these case studies take to put together and appreciate the time you have taken to share this with others

Great work, take care.......Steve

liviu2004
TwoWaves
TwoWaves
Posts: 307
Joined: Sat Mar 19, 2016 8:23 am
Location: Netherlands

Re: Discovery intermittent EML

Post by liviu2004 »

Hello, hard worked diag indeed. I’m at loss if the same garage you work for changed turbo and throttle body unnecessarily?

j-reed32
Newbie
Posts: 1
Joined: Tue Feb 02, 2021 4:44 pm

Re: Discovery intermittent EML

Post by j-reed32 »

Great diagnosis Iam a master tech for JLR so know how it feels to have intermittent faults like these thrown at you

Post Reply