CAT C7 ACERT HEUI Engine

Ask for and share advice on using the PicoScope kit to fix Heavy Duty and Off Highway machinery here
Post Reply
ben.martins
Pico Staff Member
Pico Staff Member
Posts: 271
Joined: Tue May 16, 2017 1:02 pm

CAT C7 ACERT HEUI Engine

Post by ben.martins »

Hello all,

Following on from a post by RyanH on HEUI injectors - viewtopic.php?p=101386#p101386, I'm just going to start of a discussion here where any comments and advice or experience are welcomed on diagnosing these engines.

Bit of a running issue on this one and no doubt will turn in to a case study! I've been working with someone with a CAT loading shovel with a C7 ACERT HEUI engine fitted. Customer complaint being an extreme extended crank after standing for a couple of days. Once running, restarting the engine is fine. Couple of other points to make is the fuel tank was accidently filled with antifreeze. Unsure as to whether this fault was present before this happened but it is very present now. Other observations are a new low pressure pump has been fitted and the engine emits white smoke which smells rich in fuel and blows perfect smoke rings!

I've been out to the machine and grabbed some initial data and since come away to refresh my very limited knowledge on the HEUI system! Given that the extended crank is the issue with the engine eventually firing and starting, the 8 channel scope was used to get a better view of what the engine was doing during startup.
CAT C7 cranking cold start.png
As you can see, two cranking attempts were made using starter current as a way of triggering the scope to ensure nothing was missed. The key ones to take note of here are the fuel pressure and the high oil pressure used to drive the injectors during operation. You'll notice in the first capture that it does appear to fire once but doesn't continue. During this phase high pressure oil and fuel pressure also rises but then drops. On the second attempt you can see that the high pressure oil changes as before, yet the fuel pressure pretty much flat lines.

I have been fortunate to get to a known good machine but with limited time before it was due to put into service, I limited my capture to a 4 channel. In some ways this helps maintain focus when testing! This machine had been left from a Friday evening to our testing first thing Monday morning and with the temperatures in the UK at the moment, it's a definite cold start test! Signals captured were start current again, Cyl 1, (I believe) injector current, primary timing sensor and fuel pressure.
C7 Known good.png
PSDATA file attached.

We can see here that after about 3 secs the fuel pressure rises rapidly as the combustion begins to increase the engine speed and so driven the fuel pump faster than the starter motor.

When I've measured the fuel pressure at 3 secs for the faulty machine, the voltage is 770mV. The known good machines fuel pressure sensor voltage at 3 secs is 1.325V. A significant difference between the two and enough to prompt further testing. Just looking at cranking speed there was a small difference between the two captures with the faulty machine around 250RPM and the known good 270RPM. Batteries on the faulty machine are not the greatest!

In hindsight, I wish I had lost the starter motor current on the known good capture and put on the HEUI oil pressure to see if these were the same. If someone was able to get to known good machine before me I would love to see that capture!

Looking at what we currently know it would appear fuel pressure is an area we need to prove good or bad and the plan is to cap the regulator to see if pressure rises quicker and also to restrict the fuel line into the fuel gallery to prove/disprove the lift pump. This has been replaced but you don't know till it's ruled out.

I'd love to hear anyone else's thoughts on this. As I've said, I'm not familiar with this engine or it's quirks and if anyone has any further thoughts or advice please share away!

Kind regards

Ben
Attachments
Biffa known good start up.psdata
(10.36 MiB) Downloaded 19 times
Last edited by ben.martins on Thu Jan 21, 2021 4:19 pm, edited 1 time in total.

muttnjeff
OneWave
OneWave
Posts: 46
Joined: Tue Jul 21, 2020 7:19 pm

Re: CAT C7 ACERT HEUI Engine

Post by muttnjeff »

My 2 Cents, in no specific order, put new batteries in (or a good charge), clean the cable connections, don't think this is the problem but would be good to know if this is what is driving the apparent low volts on the fuel PSI and any other questionable results between the two machines.

Continuing on the fuel path, WPS 500 or mech gage and check low and high PSI circuit for build and hold PSI, however based on your desc. of the machines issue I think fuel is not as likely an issue.

Would also like to know the hours on the machine, maintenance records (IF available), overall conditions of machine.

HEUI is VERY dependent on oil PSI, it sounds like you may have a oil PSI leak-down or PSI increase problem that driving this issue.
Not familiar with the testing options but I would think galley for injector oil PSI should have a test/tap point for the WPS500, check the cranking pressure on a KOEC (no start), (KOES) engine cranking to start and finally a leak down after engine off.

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 271
Joined: Tue May 16, 2017 1:02 pm

Re: CAT C7 ACERT HEUI Engine

Post by ben.martins »

Thanks muttnjeff,

The batteries are still a concern of mine but the plot thickens. The customer I've been supporting has now been back to the machine where the outlet of the lift pump was removed in order to cause a restriction in the attempt to section of the fuel side to determine a possible leak. What they found was very little change and when removing the restrictor and running the pump into a drum, hardly any fuel was flowing.

I've not been back to take any more recordings on this side but it considering the lift pump is driven off the back of the HEUI pump then we're now concerned the that the drive from the HEUI to the lift pump is potentially slipping resulting in a lack of flow which in tern means a lack of pressure. From what I've read these fuel pumps have an internal regulator which is set to around 90 psi, higher than the main fuel regulator on the back of the head which is expected.

Hours for this machine are 9293 and I don't have access to the service records. Whilst the oil was black, it didn't appear too thick. I know this doesn't mean anything but it wasn't anything that I was too concerned with at the time. I know the HEUI system is extremely reliant on good clean engine oil in order to actuate the injectors which is why I made sure I could get to the IAP sensor on the initial 8 channel capture. The fact the was a change in pressure that went up reasonable quickly meant I wasn't looking too closely at this side of the system.

Hindsight being a wonderful thing I wish I had sacrificed a channel in the known good capture for the IAP sensor. Maybe this is something I have to revisit.

Thanks again for your input muttnjeff, appreciated as always.

Kind regards

Ben

RyanH
OneWave
OneWave
Posts: 10
Joined: Sun May 02, 2010 12:38 am

Re: CAT C7 ACERT HEUI Engine

Post by RyanH »

I feel that you are on the right track with the fuel supply. It might be worth checking for a restriction before the supply pump as well.

Post Reply