Picoscope 4425-030 wont connect to laptop

Ask any non-NVH related questions about using PicoDiagnostics software here.
Post Reply
Wealer
OneWave
OneWave
Posts: 17
Joined: Fri Apr 15, 2022 2:19 pm

Picoscope 4425-030 wont connect to laptop

Post by Wealer »

Hi there,

I`m having problems connecting my Pico to a new laptop (Dell Latitude 5500). When I connect the scope I get the dong to confirm the usb connection but the scope doesn`t click and doesn`t communicate, also the led on the scope doesn`t go green but stays red. I can only chose demo mode in PS7. The laptop has USB 3.1 ports with the ss logo thats also on the blue Pico USB cable.

My older older Getac S410 has 2 USB 3.0 ports that don`t work either but it also has a USB 2.0 that does work.

Anyone know how to make my Pico work with this Dell laptop?

Thanks...

User avatar
PicoKev
TwoWaves
TwoWaves
Posts: 236
Joined: Thu Apr 05, 2012 9:16 am

Re: Picoscope 4425-030 wont connect to laptop

Post by PicoKev »

Have a read of this post ⇒ https://www.picoauto.com/support/topic23312.html
And see if it helps.

If not email support@picoauto.com

Make sure you give them the full details of the hardware you are using, the windows version and the pico software version. I am assuming (yes.. Dangerous I know!) that you are using a genuine Pico USB lead, as we all know that not all leads are created equal! :D

Regards,
Kev.

Steve Smith
Pico Staff Member
Pico Staff Member
Posts: 1567
Joined: Sun Aug 25, 2013 7:22 am

Re: Picoscope 4425-030 wont connect to laptop

Post by Steve Smith »

Hello and thank you for the post

Could you provide the build of PS7 software you are using? (Generic or OEM build)

When connecting to the scope, do you receive an error message such as "Unsupported device"?

I ask because the 4425-030 is a VAS scope and depending on the PS7 software installed we may have a compatibility issue

Take care.....Steve

Wealer
OneWave
OneWave
Posts: 17
Joined: Fri Apr 15, 2022 2:19 pm

Re: Picoscope 4425-030 wont connect to laptop

Post by Wealer »

Hi Steve,

I`m using the generic PS7 software. Version: 7.0.116.13985

There`s no message when connecting the scope, only the dong you get when you connect a USB device.

I also tried the Pico for VAS software version: 7.0.116.1374. It does the same thing.

I changed the USB settings according to this thread https://www.picoauto.com/support/topic23312.html didn`t make a difference.
I also tried powering a 5w testlight with the USB 3.1 port and that works, so the USB port is capable of delivering some current. I don`t think a power USB hub would make much difference.

Steve Smith
Pico Staff Member
Pico Staff Member
Posts: 1567
Joined: Sun Aug 25, 2013 7:22 am

Re: Picoscope 4425-030 wont connect to laptop

Post by Steve Smith »

Hello and thank you for the feedback

Just reading through the posts, you mentioned the 4425-030 scope works OK with a USB 2.0 port on your Getac machine?

I ask because this confirms the scope to be OK

Kev also mentioned using the genuine Pico Blue USB cable, could you confirm this is the case?

Could you confirm that the scope is not working with either PS7 or PicoDiagnostics?

When connecting your scope to the Dell Laptop could you open the Device Manager and check the PicoScope is visible? (see image below)
DM
DM
Could we confirm all essential and recommended Windows updates have been actioned on the Dell machine (.Net springs to mind)

I hope this helps and I look forward to any feedback

Take care……Steve

Wealer
OneWave
OneWave
Posts: 17
Joined: Fri Apr 15, 2022 2:19 pm

Re: Picoscope 4425-030 wont connect to laptop

Post by Wealer »

Hi Steve,

I`ve tried several laptops, it always works on USB 2.0 ports and never works on USB 3.0 or 3.1

Yes I`m using a new blue Pico USB cable.

Pico diagnostics also doesn`t work.

In the device manager on the Dell laptop I can see the pico when its connected.

Laptop is up te date.

I`ve sent a email to: support@picoauto.com They think the issue is the scope itself and want it sent to them for repair.

Post Reply