TA473 60A BNC+ Current Clamp

Ask any questions relating to the PicoScope hardware or kit contents here.
If you have any questions prior to purchasing the kit post them here.
ben.martins
Pico Staff Member
Pico Staff Member
Posts: 550
Joined: Tue May 16, 2017 1:02 pm

TA473 60A BNC+ Current Clamp

Post by ben.martins »

Hi all,

Hope all are well. I've put together a very short video showing a technique that we've been looking into.

It involves connecting a current clamp to the CAN H or CAN L wiring on a branch of a network. The idea is that despite the fast switching of data taking place there will be a change in current and thanks to the fast response of the TA473 we can actually pick out the current relating to the packet. Steve Smith did pick up on using a current clamp on CAN in the following post - viewtopic.php?p=98241#p98241 but we can see the limitations where there might be multiple packets.

Hopefully though you'll notice in the video that the TA473 gives enough detail to try a different technique when looking for CAN related faults.



Hope this helps and please give it a try if and when you can and let us know what you find.

Kind regards

Ben

picowight
TwoWaves
TwoWaves
Posts: 177
Joined: Sat Oct 26, 2019 6:45 pm

Re: TA473 60A BNC+ Current Clamp

Post by picowight »

This is a brilliant concept that I am going to try out (on a known good) as soon as possible.
It should work with serial comms too.
Thinking about it, if you unplug the module at the end of the branch, it would show voltage on the network side but no current going to the module as there is no circuit. If that is correct could it be used to test network continuity vs dead module, remotely to a difficult to access module? - Might be misleading if the module has lost ground though.

picowight
TwoWaves
TwoWaves
Posts: 177
Joined: Sat Oct 26, 2019 6:45 pm

Re: TA473 60A BNC+ Current Clamp

Post by picowight »

Since the TA496 has the same speed but slightly less resolution would that work for this application?

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 550
Joined: Tue May 16, 2017 1:02 pm

Re: TA473 60A BNC+ Current Clamp

Post by ben.martins »

Hi picowight,

Great question and I can say the TA496 does still work OK with this application. The same vehicle and position was tested as the one in the video.

It had around 10kHz of lowpass filter added to the current trace and this was where the ignition was switched off. Network speed for both clamps was 500kBaud.

Not sure why but I can't seem to add attachments but I will post the image as soon as I can.

Kind regards

Ben

alaskatim
Newbie
Posts: 1
Joined: Thu Feb 14, 2019 6:23 am

Re: TA473 60A BNC+ Current Clamp

Post by alaskatim »

Don't know if this is where I should post this here but here goes.
Does anyone else have a problem with their TA473 coming up as an unsupported probe? It is frustrating. I have tried cleaning the connections with alcohol and a swab but it still happens all the time. I have an EV kit with the 4425a and none of my other bnc+ probes do this.

Steve Smith
Pico Staff Member
Pico Staff Member
Posts: 1633
Joined: Sun Aug 25, 2013 7:22 am

Re: TA473 60A BNC+ Current Clamp

Post by Steve Smith »

Hello and thank you for the post

Could you confirm the software version you are using and also try the latest Early Access build here https://www.picoauto.com/downloads to see if the symptom persists?

If we have no joy, could you email support@picotech.com and we can make the necessary arrangements to get this resolved

I hope this helps, take care.....Steve

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 550
Joined: Tue May 16, 2017 1:02 pm

Re: TA473 60A BNC+ Current Clamp

Post by ben.martins »

Hello all,

Apologise for the delay but it now looks like the forum is accepting attachments again.

As promised here is the image from the TA496 current clamp on CAN.

Kind regards

Ben
Attachments
TA496 on CAN.png

picowight
TwoWaves
TwoWaves
Posts: 177
Joined: Sat Oct 26, 2019 6:45 pm

Re: TA473 60A BNC+ Current Clamp

Post by picowight »

That's great, thanks.
Looks like only one way comms in that waveform !

picowight
TwoWaves
TwoWaves
Posts: 177
Joined: Sat Oct 26, 2019 6:45 pm

Re: TA473 60A BNC+ Current Clamp

Post by picowight »

So I bought a TA496 and it is just great! Never realised how much of a faf setting up an Amp clamp was until you use one that you just plug in, no batteries, no scale setting, no auto switch off (or not!). 5ma -60A is perfect for just about everything except an RC test. Smaller jaws are a bonus too.
Over all just a great bit of kit to work with, not cheap but if you use your scope professionally - (and why else would you have a 4425a!) it is well worth the money.

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 550
Joined: Tue May 16, 2017 1:02 pm

Re: TA473 60A BNC+ Current Clamp

Post by ben.martins »

Hi picowight,

Thank you for the feedback and glad you like the clamp. I will pass your kind words along to the hardware team that put that clamp together.

Thanks again.

Kind regards

Ben

Post Reply