spark occuring 2.5 msec after coil primary grounded?

Ask for and share advice on using the PicoScope kit to fix vehicles here.

spark occuring 2.5 msec after coil primary grounded?

Postby hillp » Tue Mar 04, 2014 4:29 am

Troubleshooting an HC emissions failure, slightly rough idle on a distributor ignition system, 94 Chevy Suburban 5.7 liter. There's an electronic ignition module that fires the coil. It was replaced a few weeks ago along with the coil, plug wires, and plugs; the old one was misfiring horribly. Pickup coil's never been changed in 360K miles. The dwell period before the spark occurs seems to be divided into 2 sections. The first section looks like the one I expect, but there's only a slight blip when the primary is grounded, and then it takes another 2.5 msec or so before the spark actually fires. Seems to me that the spark should have occurred as soon as the primary was grounded. ??
Attachments
pri and sec.psdata
(6.53 MiB) Downloaded 158 times
hillp
User
User
 
Posts: 17
Joined: Wed Feb 11, 2004 11:04 pm

Re: spark occuring 2.5 msec after coil primary grounded?

Postby Fat Freddy » Tue Mar 04, 2014 9:45 am

Chuck on the Amp clamp. I think you will find it's going into current control.
It's not fully switched off.
20140304-0002.gif
Couldn't help it.
User avatar
Fat Freddy
Zen Master
Zen Master
 
Posts: 267
Joined: Fri May 04, 2012 4:52 am

Re: spark occuring 2.5 msec after coil primary grounded?

Postby hillp » Sun Mar 09, 2014 12:34 pm

Yes, Fat Freddy, that seems to be it. Thanks.

Do you know what the periodic current events are (green trace) that seem to be occurring during the coil's quiet time?
Attachments
ignition current dips.pdf
(51.78 KiB) Downloaded 147 times
hillp
User
User
 
Posts: 17
Joined: Wed Feb 11, 2004 11:04 pm


Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests