focus 2005 petrol injector wavform

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

focus 2005 petrol injector wavform

Postby nick_at_home » Mon Sep 23, 2013 11:15 am

hi guys
I have a ford focus 2000cc with a duratec engine which is lumpy at idle I replaced the plugs and coil packs before starting diagnostics, the car had a lpg retrofit kit fitted which during investigation was removed , the engine is showing no fault codes so out came the scope.
I have checked the crank and cam shaft sensors (trace attached below) and they seem to be fine.
crank v cam.BMP
crank v cam.BMP (281.3 KiB) Viewed 2027 times

But the petrol injectors are pulsing after the main pulse which is timed correctly intermittently about 30% of the time on all four cylinders and can be seen in the scope trace .
crank v injector.BMP
crank v injector.BMP (281.3 KiB) Viewed 2027 times


as everything else seems ok any ideas ? is this an ecu fault? would you expect a trace like this from a petrol injector?

thanks in advance

nick
nick_at_home
Newbie
 
Posts: 1
Joined: Mon Sep 23, 2013 10:59 am

Re: focus 2005 petrol injector wavform

Postby Robski » Tue Sep 24, 2013 11:45 am

Secondary ign captures with exh pulses so we can work out the misfire type/cylinders(s) at fault ?

It will be difficult to view/manipulate your captures as this is a forum related to the Picoscope.

Fuel trims ?

Looks possible the injector pulse has gone asynchronous.
Duratec HE_1.8_CMP inj #1.JPG
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: focus 2005 petrol injector wavform

Postby Karl winter(KarlW) » Wed Sep 25, 2013 2:04 pm

Nick,
Not sure if this will help you. here is a 2003 Focus 2.0L Zetec. Hard to tell but your cam transition seems to be at 70 deg ATDC. Still in PIP high(bearly) window BUT That's probably why its not coding??? The file I have is 50 deg. ATDC. Like I said hard to tell. Hope this helps you.

Karl
Attachments
pico forums 2 0L Focus.jpg
User avatar
Karl winter(KarlW)
User
User
 
Posts: 13
Joined: Mon Sep 10, 2012 3:40 pm
Location: Somerville, Massachusetts

Re: focus 2005 petrol injector wavform

Postby Fat Freddy » Thu Sep 26, 2013 2:32 am

I have a ford focus 2000cc with a duratec engine which is lumpy at idle


I could be wrong but that second image seems odd. To me that looks like 1400RPM ???? Have I misread that?

If that is the case you must be using the throttle. That injection may not be a fault.

Really need more captures as Robski mentioned to ID cyl.

the car had a lpg retrofit kit fitted


Depending on vehicle/engine and miles valves and seats would be at the back of my mind for a lumpy idle.


HTH
FF
User avatar
Fat Freddy
Zen Master
Zen Master
 
Posts: 267
Joined: Fri May 04, 2012 4:52 am


Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 1 guest