Mondeo 2.0 TDCI non start

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

Mondeo 2.0 TDCI non start

Postby GRUSS » Tue Sep 03, 2013 8:33 pm

I'm not a ford man but a family member has asked me to look at there mondeo.

It cut out and wouldn't restart whilst driving. Hooked up my Texa and retrieved P2291 injector control pressure too low- engine cranking.
Looking at live data whilst cranking I'm getting 75bar max fuel pressure.

I've checked for voltage at the in tank pump and I'm getting nothing. Looked on AD and my Texa but can't find a wiring diagram for the in tank fuel pump...

attempted to use my power probe direct at the pump but nothing! Is there even a pump in there?
GRUSS
Guru
Guru
 
Posts: 119
Joined: Tue Dec 27, 2011 11:16 pm

Re: Mondeo 2.0 TDCI non start

Postby antthecat » Tue Sep 03, 2013 8:47 pm

There is no in tank lift pump, has a vac pump on back of HP pump.

Injectors can have vast leak back causing low rail pressure.
antthecat
Advanced User
Advanced User
 
Posts: 70
Joined: Fri Dec 23, 2011 8:58 pm

Re: Mondeo 2.0 TDCI non start

Postby GRUSS » Tue Sep 03, 2013 8:51 pm

Thanks for clearing that up for me...

I've done a few that have lost injection coding but all these are correct.

is it possible to do a leak off with the engine not running?

Heard the filters can block on these?
GRUSS
Guru
Guru
 
Posts: 119
Joined: Tue Dec 27, 2011 11:16 pm

Re: Mondeo 2.0 TDCI non start

Postby antthecat » Tue Sep 03, 2013 9:06 pm

Tee in a vac gauge in to supply line (ensuring pipe is purged of air) and measure vac supply after filter.

You can use leak off bottles on cranking.

As you know injector fail can be caused by failing HP pump.
antthecat
Advanced User
Advanced User
 
Posts: 70
Joined: Fri Dec 23, 2011 8:58 pm

Re: Mondeo 2.0 TDCI non start

Postby Robski » Tue Sep 03, 2013 11:06 pm

antthecat wrote:There is no in tank lift pump

how do you know this without an MY for the car ?

is there even a pump in there?

not 'inside' the tank no. MY dependant.
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Mondeo 2.0 TDCI non start

Postby GRUSS » Wed Sep 04, 2013 12:02 pm

I did reply earlier but seems to have gone AWOL!?!

It's a 2005.
GRUSS
Guru
Guru
 
Posts: 119
Joined: Tue Dec 27, 2011 11:16 pm

Re: Mondeo 2.0 TDCI non start

Postby antthecat » Wed Sep 04, 2013 10:31 pm

I've never seen a lift pump on a mondeo tdci(mk 3 vintage) but have seen a lift pump near the tank on mk3 tddi vehicles.
antthecat
Advanced User
Advanced User
 
Posts: 70
Joined: Fri Dec 23, 2011 8:58 pm

Re: Mondeo 2.0 TDCI non start

Postby Robski » Wed Sep 04, 2013 10:59 pm

antthecat wrote:I've never seen a lift pump on a mondeo tdci(mk 3 vintage) but have seen a lift pump near the tank on mk3 tddi vehicles.

same place for TDCI if it has one fitted, few & far between.
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Mondeo 2.0 TDCI non start

Postby antthecat » Thu Sep 05, 2013 4:53 pm

They must be rare, service/maintain/diagnose hundreds of the tdci mk3's and never seen one, will now bear in mind the next time one is in
antthecat
Advanced User
Advanced User
 
Posts: 70
Joined: Fri Dec 23, 2011 8:58 pm

Re: Mondeo 2.0 TDCI non start

Postby Robski » Thu Sep 05, 2013 6:25 pm

antthecat wrote:They must be rare, service/maintain/diagnose hundreds of the tdci mk3's and never seen one, will now bear in mind the next time one is in

I'm trying to track the owner down,it was a long time ago, I was gob smacked it had a pump & 99.9% sure it was TDCI.

Have a browse on a well know auction site.
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire


Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 0 guests