C3 pluriel 1.4

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

C3 pluriel 1.4

Postby nrg123 » Tue Jun 11, 2013 2:21 pm

HELP! I have a 2007C3 Pluriel that is hard to start and eventually can run to temp, it will not rev past 2500rpm and all live data is all over the place. I have inj dur times of no1 18.84ms, no2 117.15ms, no3 208.90ms (and static) no4 36.86ms. yes thats what it says on our snap on verdict.O2 sensor says weak, sens1 bank 1 547mv constant, sens 2 2702mv ! and as for battery voltage this reads 0v and when at 0v its hard to start. We found a couple of pins in ECM with slight corrosion and since cleaning it now revs and starts ok but the above readings are all over the place and we have a battery voltage of 0 to 5+ volts fluctuating and dropping in and out.. Before ecm pins being cleaned the car initially would not rev and CAT would glow if held at 2000rpm, disconnected it and no blockage. Fuel pressure a constant 4 bar and smoke test shows no air leaks.We also have no fault codes and no MIL light on and emissions at tail pipe are all ok. Tried to find wires supplying the Ecm but nothing corresponds to autodata diagram. ANY SUGGESTIONS WOULD BE APPRECIATED.
Posts: 1
Joined: Tue Jun 11, 2013 6:51 am
Location: norfolk

Re: C3 pluriel 1.4

Postby arjen » Tue Jun 11, 2013 7:52 pm

What scantool are you using? I think you have to use another scantool. The injection duration and voltage suply you mention cannot be correct.
Posts: 49
Joined: Wed Mar 06, 2013 7:18 pm
Location: Drachten, Holland

Re: C3 pluriel 1.4

Postby Robski » Tue Jun 11, 2013 8:19 pm

sounds like a system mismatch to me ............
User avatar
Advanced User
Advanced User
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: C3 pluriel 1.4

Postby SamP » Thu Aug 01, 2013 8:57 pm

Hello buddy,
It seems like some ecu problem,
focus closer on injectors if your cat is glowing red, see what's ecu command and what ammouns are injected.
Hope it helped a bit. Keep us updated. :D
Posts: 4
Joined: Mon May 06, 2013 5:49 pm

Re: C3 pluriel 1.4

Postby mteste03 » Fri Aug 02, 2013 6:36 pm


I agree with Rob; either get it on another tool or confirm the results you are reading with your scope.

What are the actual 4 gas results

Posts: 40
Joined: Mon Oct 29, 2012 9:14 pm

Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 0 guests