rover 25 p0722

Ask for and share advice on using the PicoScope kit to fix vehicles here.

Re: rover 25 p0722

Postby Neilcur » Wed Mar 06, 2013 9:58 pm

Hi

Found a wiring diagram on net but its quite blurry is it is a trail and signal wire goes to engine ecu but found this info on another site and according to it the GIU (gearbox interface unit there name for TCM) doesn't control the signal from sensor i am testing so it looks the the ecu deals with the sensor input.

Complaint:
Car Will Not Achieve More Than 2000rpm, Stuck in Single Ratio
Fault Code P0722 Logged

Check:
Output Speed Sensor Circuit – Use Test-book in Real Time Monitor (CVT Parameters) to See If Road Speed Signal Ok
Check for Debris Across Sensor Pick - up
Substitute MEMS ECM if Signal and Wiring Ok
Neilcur
Advanced User
Advanced User
 
Posts: 68
Joined: Sun Feb 17, 2013 7:47 pm
Location: South West Scotland

Re: rover 25 p0722

Postby arjen » Wed Mar 06, 2013 10:05 pm

Just had a look at the meassurings.
Looks to me like your sample rate is to low.
Because of this it looks like the voltage drops down when the frequense rises.

If you send me your email adres then I can send you a wiring diagram.
Last edited by arjen on Thu Mar 07, 2013 7:12 am, edited 1 time in total.
arjen
Advanced User
Advanced User
 
Posts: 50
Joined: Wed Mar 06, 2013 7:18 pm
Location: Drachten, Holland

Re: rover 25 p0722

Postby mteste03 » Wed Mar 06, 2013 10:08 pm

Hi,

Call autodata and see if they can look up some more detailed info, they have access to much more than they can put on CD etc.

Does this gearbox have a input shaft speed sensor, if so could well be same sensor and you could swap and see if fault changes.

When fault occurs are there any signs of mechanical faults?

Matt
mteste03
User
User
 
Posts: 40
Joined: Mon Oct 29, 2012 9:14 pm

Re: rover 25 p0722

Postby Neilcur » Wed Mar 06, 2013 10:18 pm

Hi,

I will maybe phone them tomorrow and see what they say about a diagram, There is a road speed transducer sensor, output speed sensor, an inhibitor switch and a ratio control motor. No signs of mechanical faults took the car a 20 mile run and didn't miss a beat, stopped, 10 mins later took it a run again and it happened within a mile so i stopped and left car turned off for 5 mins then drove back to workshop and it was fine again so its a strange one!

Thanks Neil
Neilcur
Advanced User
Advanced User
 
Posts: 68
Joined: Sun Feb 17, 2013 7:47 pm
Location: South West Scotland

Re: rover 25 p0722

Postby KimAndersen » Thu Mar 07, 2013 11:05 am

Hi Neil

I have looked at your so called good speed sensor again and it looks like the supply voltage to the speed sensor are missing sometimes !!!.

At first eye sight, I thought the signal was missing and indeed it does, but I´m more and more convinced that somewhere at the supply wire, that the voltage is being disturb - it could also be that sensor itself is shortcircuited.

With the help of the right wiring diagram i´m sure you will be able to pinpoint this problem correctly. :wink:

Regards
Kim

SUPPLY_VOLTAGE_MISSING.jpg
KimAndersen
Guru
Guru
 
Posts: 159
Joined: Fri Nov 30, 2012 2:53 pm
Location: Denmark

Re: rover 25 p0722

Postby Neilcur » Thu Mar 07, 2013 11:37 am

Hi Kim,

I think at the point you have mentioned i stopped the car, turned ignition of, restarted car and drove back to workshop but i can't quite remember but that would account for why the supply dropped and came back at that point. If you look at my 'bad' capture the signal stays at 14v the entire capture while the signal is dropping off and fault occurs but i'd have to redo the capture to be sure. I will redo it at some point just trying to find time among other jobs.

Thanks Neil
Neilcur
Advanced User
Advanced User
 
Posts: 68
Joined: Sun Feb 17, 2013 7:47 pm
Location: South West Scotland

Re: rover 25 p0722

Postby arjen » Thu Mar 07, 2013 12:09 pm

The correct wiring diagram should be in your mailbox now.
arjen
Advanced User
Advanced User
 
Posts: 50
Joined: Wed Mar 06, 2013 7:18 pm
Location: Drachten, Holland

Re: rover 25 p0722

Postby Neilcur » Thu Mar 07, 2013 6:48 pm

Hi,

Got wiring diagram. Thank you for that will try and scope sensor tomorrow at engine ecu and see what happens.

Thanks Neil
Neilcur
Advanced User
Advanced User
 
Posts: 68
Joined: Sun Feb 17, 2013 7:47 pm
Location: South West Scotland

Re: rover 25 p0722

Postby Robski » Thu Mar 07, 2013 7:12 pm

Got a rover 25 in throwing up a p0722 code for automatic transmission output speed sensor fault


What scanner ? & that's not the description i have for it !
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: rover 25 p0722

Postby Neilcur » Thu Mar 07, 2013 7:17 pm

Autodiagnos multi tester pro. What does your description say?
Neilcur
Advanced User
Advanced User
 
Posts: 68
Joined: Sun Feb 17, 2013 7:47 pm
Location: South West Scotland

PreviousNext

Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests