Vauxhall Corsa y13dt Barometric problem!

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

Vauxhall Corsa y13dt Barometric problem!

Postby bullstar » Wed Feb 13, 2013 8:07 pm

Hi all
Just had a vauxhall Corsa van 1.3 cdti in and customer says van is loosing power and going into limp mode somtimes and seems like the car is not boosting.

I pulled the codes out using Autoboss v30, The DTC said: P0108 - 7 undefined trouble code.

Live data said Barometric pressure 99 kpa and volts said 3.7 this data stayed the same on idle, throttle,and with just key on position!

Boost pressure 94 kpa and 1.76 v on idle, Boost pressure reading were up under load.

The customer has fitted new egr valve, map sensor and maf meter.

Could this be due to wastegate not opening and ECU shutting down? Any help forward would be appriciated :D

What should the pressure be in the inlet manifold?

I hooked the scope up to the map sensor and this is what the reading was:

corsa map.psdata
(353.26 KiB) Downloaded 238 times
bullstar
User
User
 
Posts: 27
Joined: Wed Nov 21, 2012 9:48 pm

Re: Vauxhall Corsa y13dt Barometric problem!

Postby KimAndersen » Wed Feb 13, 2013 9:05 pm

Hi Bullstar
DTC P0108 mean ( Manifold Absolute Pressure Circuit High Voltage )

Kim
Last edited by KimAndersen on Thu Feb 14, 2013 2:24 pm, edited 2 times in total.
KimAndersen
Guru
Guru
 
Posts: 159
Joined: Fri Nov 30, 2012 2:53 pm
Location: Denmark

Re: Vauxhall Corsa y13dt Barometric problem!

Postby Robski » Wed Feb 13, 2013 9:07 pm

Get another scan tool on it for a better DTC description !

MAP/Baro @ KOEO ??

Live data said Barometric pressure 99 kpa and volts said 3.7 this data stayed the same on idle, throttle,and with just key on position!


It will, you do know what Barometric pressure is yes ?
I don't know where you are in the world or elevation ??

What should the pressure be in the inlet manifold?


Actual V Specified ?

Boost pressure 94 kpa and 1.76 v on idle, Boost pressure reading were up under load.


What's that mean ?

Could this be due to wastegate not opening and ECU shutting down?


Again Actual V Specified ?

I hooked the scope up to the map sensor and this is what the reading was


Under what condition ?

Where's the parts from fitted previously ?
Scope MAF V MAP V TPS if you have enough channels & post.
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Vauxhall Corsa y13dt Barometric problem!

Postby bullstar » Wed Feb 13, 2013 9:10 pm

Hi Kim,

Thanks for your reply,

My scanner was saying 3.7v all the time but on the scope it is reading about 1.8 v at idle so would you agree the scope was right and my scanner reading wrong?

Regards Colin.
bullstar
User
User
 
Posts: 27
Joined: Wed Nov 21, 2012 9:48 pm

Re: Vauxhall Corsa y13dt Barometric problem!

Postby bullstar » Wed Feb 13, 2013 9:23 pm

Hi Robski,
Thanks for your reply,

Im new to the scope and have a lot to learn so go easy :shock: !

I do know what barometric pressure is and live in Durham UK so not unusally elevated.

I will scope map, maf and tps and upload data soon

All I know about the parts were bought new from a local motor factors.

regards Colin.
bullstar
User
User
 
Posts: 27
Joined: Wed Nov 21, 2012 9:48 pm

Re: Vauxhall Corsa y13dt Barometric problem!

Postby Robski » Wed Feb 13, 2013 9:37 pm

Im new to the scope and have a lot to learn so go easy !


Was that hard like ? Only offering advice & tactics :shock: !

All I know about the parts were bought new from a local motor factors.


Fatal especially MAF !

MAF value @ idle with no EGR ?
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Vauxhall Corsa y13dt Barometric problem!

Postby bullstar » Wed Feb 13, 2013 9:42 pm

Hi Robski

I know thanks and really appriciate your info and time :D

Ill scope the sensors and update post soon

Thanks again Colin.
bullstar
User
User
 
Posts: 27
Joined: Wed Nov 21, 2012 9:48 pm

Re: Vauxhall Corsa y13dt Barometric problem!

Postby KimAndersen » Wed Feb 13, 2013 10:08 pm

Hi Colin

I would trust my picoscope if i were you.
I have managed to find the right specifications on this map sensor Bosch # 0281002844 - that will say how the scale are.

Lower value: 400 millibar = 688...823 mV
Upper value: 2100 millibar = 3833...3968 mV

There must be something else wrong since the map sensor already is replaced - i am tempted to say - that the turbo filled with large amount of carbon deposit !

Any codes for overboosting !

Kim
KimAndersen
Guru
Guru
 
Posts: 159
Joined: Fri Nov 30, 2012 2:53 pm
Location: Denmark

Re: Vauxhall Corsa y13dt Barometric problem!

Postby bullstar » Wed Feb 13, 2013 10:24 pm

Hi Kim

Thanks for info,

There was no codes stored for overboosting, Im going to hook the scope up again for map , maf and throttle position sensor and add file for viewing tomorrow evening.

I know these engines are bad for carbon build up and reckon on the turbo or actuator but really want to make correct diagnostic for customer.

Customer did say egr had a lot of carbon build up on it!

Regards Colin.
bullstar
User
User
 
Posts: 27
Joined: Wed Nov 21, 2012 9:48 pm

Re: Vauxhall Corsa y13dt Barometric problem!

Postby GRUSS » Thu Feb 14, 2013 7:49 am

What make is the map sensor fitted?
I've had experiences with poor non gen maps before. Have you tested the full circuit ie powers and ground and sensor signal integrity etc.

The circuit should be a pull down design ie 5v when unplugged if I remember right. If that's the only code you have and no boost deviation ones then I'd be focusing there first.

Although did you say a motor factors maf was fitted?

Also the inlet manifold are prone for blocking up as well as the valves with carbon buildup on really high mileage engines.
GRUSS
Guru
Guru
 
Posts: 119
Joined: Tue Dec 27, 2011 11:16 pm

Next

Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 0 guests