Skoda 1.4 tdi crank sensor

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.
crcoops
OneWave
OneWave
Posts: 16
Joined: Tue Dec 04, 2012 10:29 pm

Skoda 1.4 tdi crank sensor

Post by crcoops » Mon Dec 10, 2012 5:41 pm

Hi can any one help with this wave form think the sensor isn't giving enough voltage it's a 2006 skoda fabia 3 cly diesel thanks.
Attachments
image.jpg

User avatar
Robski
Advanced User
Advanced User
Posts: 597
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Skoda 1.4 tdi crank sensor

Post by Robski » Mon Dec 10, 2012 6:00 pm

Is that cranking ?

And why don't you post the file rather than a screen shot ?

An explanation of the fault/DTC's goes a long way too !

crcoops
OneWave
OneWave
Posts: 16
Joined: Tue Dec 04, 2012 10:29 pm

Re: Skoda 1.4 tdi crank sensor

Post by crcoops » Mon Dec 10, 2012 6:27 pm

The code is 16705/p0321 rpm implasble signal the car fires up on two cylinders the after 20/30 seconds comes in on three but it won't rev up and starts spluttering.

I can't up load it because can only do it off my phone no wifi at work.

The engine is running

Cheers

User avatar
Robski
Advanced User
Advanced User
Posts: 597
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Skoda 1.4 tdi crank sensor

Post by Robski » Mon Dec 10, 2012 6:50 pm

Does the amplitude change ?

Where have you stabbed for that capture ?

Hard work going off a screen shot we can't even see the time base ??

Amplitude looks low to me & the frequency too in that capture, what's the other side look like & what was it running like on that capture ?

KimAndersen
TwoWaves
TwoWaves
Posts: 206
Joined: Fri Nov 30, 2012 2:53 pm
Location: Denmark

Re: Skoda 1.4 tdi crank sensor

Post by KimAndersen » Mon Dec 10, 2012 11:02 pm

Here on this image which is taken from a 1.4 TDI LUPO - can you see that a full crankshaft rotation - need three separate signals per revolution.

On the image you have taken - is it difficult to see whats really is going on.

Have you inspected the wiring and the connector for possible damage or loose terminals !

You could also make a basic resistance check of the crank sensor circuit !

Try with a bigger timebase - so you can capture at least one revolution
Engine_Speed_Sensor.jpg

User avatar
Fat Freddy
TwoWaves
TwoWaves
Posts: 314
Joined: Fri May 04, 2012 4:52 am

Re: Skoda 1.4 tdi crank sensor

Post by Fat Freddy » Tue Dec 11, 2012 1:10 am

As he said. Need the file.

That screen image may have just missed the money shot. Looks like the VRS amplitude reduces further (last switch).
Can't add any more to that.

HTH
FF

crcoops
OneWave
OneWave
Posts: 16
Joined: Tue Dec 04, 2012 10:29 pm

Re: Skoda 1.4 tdi crank sensor

Post by crcoops » Tue Dec 11, 2012 11:26 am

[The extension mov has been deactivated and can no longer be displayed.]

Sorry this is the only file I can upload

KimAndersen
TwoWaves
TwoWaves
Posts: 206
Joined: Fri Nov 30, 2012 2:53 pm
Location: Denmark

Re: Skoda 1.4 tdi crank sensor

Post by KimAndersen » Tue Dec 11, 2012 3:34 pm

Hi crcoops

I have seen your movie and i think there is some disturbance of the crank position sensor signal - especially on cylinder number 2.

A other thing that i find a little odd is the position of the crankshaft signal related to the cylinder id from the camshaft senor - from the image that i early have uploaded - can you see that the cylinder id signal comes a little bit before the the crank position sensor and not the other way around - i don´t know if it´s a problem !!!
Cylinder_ID2.jpg

crcoops
OneWave
OneWave
Posts: 16
Joined: Tue Dec 04, 2012 10:29 pm

Re: Skoda 1.4 tdi crank sensor

Post by crcoops » Tue Dec 11, 2012 5:01 pm

Thanks for your help.

The story with the car is we rebuilt the engine in it two years ago and the problem has been there ever since, now it's Christmas coming up and gone a bit quite I thought I'd get my picoscope out and try and sort the problem out.

I have another pic if this will help.

Also what could cause the problem in the pic iv checked the wiring and the sensor.


Cheers

The novice scope user
Attachments
image.jpg

crcoops
OneWave
OneWave
Posts: 16
Joined: Tue Dec 04, 2012 10:29 pm

Re: Skoda 1.4 tdi crank sensor

Post by crcoops » Tue Dec 11, 2012 5:31 pm

Thanks for all the help the forth pin was ever so slightly bent inwards.

Post Reply