Mini 2001. Airbag light on....

Everyone loves a happy ending. Share your diagnostic success stories here.

Mini 2001. Airbag light on....

Postby Darren Cotton » Wed Nov 14, 2012 10:15 pm

This Mini was presented to me from a second hand car salesman, not the best customers to do work for in my opinion as their main concern is their profit and the jobs I receive from car sales plots can be in depth and he or she can be pressurising at times, as in their minds its always a quick fix. I am sure many of us can relate to this.

Well, this is exactly how it was, with this a 2001 Mini with the airbag light on and tyre pressure monitoring light was also illuminated, this was after they had a valet on the vehicle. The salesman said “If you can just plug it in and reset it” how many times do we hear that one! I was already informed that a mobile company had already been out to it and their diagnostic tool was not connecting to it.
With the buyer collecting this Vehicle at the end of the day the salesman was waiting, I attempted to see what I could do on the spot. Using Autologic, I carried out a quick scan, this feature will attempt to connect to every module for that variant. I found that we had no communication for Multiple Restraint System (MRS), Electronic Transmission Management (EGS), Radio (RAD) and Immobiliser (EWS). Maybe the mobile company’s device was telling the truth but maybe unable to handle the repair. This is obviously why we have warning lights illuminated. The advantage of using a high quality dealer level tool is that you know you can trust the information it is telling you. Keeping in mind the customer is just interested in the Airbag and the TPMS warning lights, but is this just one fault? And where do we start....?

Mini No Comms.gif


Explaining to the salesman that this is not going to be as straight forward as a “quick reset” and we are going to need time to investigate the faults. Applying pressure he asked the million dollar questions “How long will it take for you to fix and how much?” Well no one in a sane mind is going to answer that. He left the vehicle with me and I was able to put a diagnostic plan in place. The vehicle started and drove fine, radio was working OK, the TPMS is a manual reset function and would not reset. I Focused on the Multiple Restraint System and looked at the schematics of the airbag system, in fact using the BMW MINI wiring diagram system it made it very easy and a plan of attack was put into place.

Diagram.gif


So i decided to check that the 5 Amp fuse F18 for the MRS, it had a Nominal Battery Voltage (NBV) and was in good order, and the plan was to get access to the MRS module. The module is located under the handbrake lever under the carpet and was not accessible easily, the front seats were removed and the carpet lifted from the rear seats to the front of the vehicle just enough to access the module. With the diagram I was able to check the cavities shown. The supply and earth was in good order.

I wanted to check the communication Line as we do have other modules not communicating here, attaching the Picoscope to cavity 51 of the MRS module I was able to see the K-Bus signal; I also located the K-Bus at the O/S/F door sill. Capturing the K-Bus we can see what’s going on here, something was not right. On this Variant the K-BUS wire is White and Red with yellow band (WS/RT/GE)

Top and bottom captures are the same, Top trace is a zoomed in trace of the lower one.
The Green trace is K-BUS at drivers door sill, and the Red trace is K-BUS at the MRS module cavity 51.

Mini K-Bus poor.gif


The capture above is one single wire, RED trace is at AIRBAG module and GREEN trace is at Driver’s door sill. Zoomed in, the data being sent was not correct and the input voltage was at 7.5v this is also incorrect, so now I was getting somewhere, this is our problem & just need to locate the cause....

K-Bus in brief

K-Bus consists of a single copper wire and data transfer is approx 9.6Kps (Bits Per Second) and is always active when terminal R is switched on. If the bus line is quiet for more than 60 seconds all the control modules that are connected will go into sleep mode. The wire colour is uniform throughout the vehicle, WS/RT/GE (White/Red/Yellow).
Due to the linear structure of the network, K-Bus is available for other modules in the event of a disconnection or failed control unit, Just as the CAN bus, this is referred to as a tree structure with each control unit occupying a branch. The K-Bus provides a diagnostic connection to the control unit connected on those busses. The K-Bus uses only a determined controller to supply B+ for communication. The voltage level must be above 7V. The Nominal voltage should be close to NBV, in my experience a good working K-Bus is around 13v


This is the Poor K-BUS signal Zoomed in

K bus zoomed.gif


Studying the wiring diagram it led me to the BCM which on this variant is located in the driver’s side foot-well. Upon removing the module I found water ingress and the wiring harness was soaked... Unplugging the harness the cause was very clear. Corrosion to the terminals at the BCM was so bad as I unplugged it the pin had broken off.

This is the BCM you can see the pin broken

Mini BCM Broken Pin.jpg


So in a real world this needs a new BCM and a wiring harness, but this is a sales car and they do not spend money, so i came up with a plan. I opened the BCM and followed the pin back and soldered a wire to the good part inside the BCM...

BCM Repair........

mini BCM quick repair.gif


Attached the wire to the other side of the multi plug . After refitting the BCM I Carried out a global scan which gave me full communication to all modules, the TPMS reset and all is looking good. Attached the scope to the K-BUS again just for good measure...... Which confirmed the repair was a success....

Good K-Bus Signal after the repair....

K-Bus After Repair.jpg


Maybe the mobile company who looked at this first are looking for the quick repairs or do not have the confidence of the repair, once the system is understood the process becomes easier and It goes to show that one device is just not enough, the picoscope in this situation definitely helped in the diagnosis, hard to prove otherwise......

Darren
Darren Cotton
Advanced User
Advanced User
 
Posts: 52
Joined: Thu Jun 16, 2011 9:53 pm

Re: Mini 2001. Airbag light on....

Postby Robski » Thu Nov 15, 2012 5:09 am

Top stuff Darren nice work & a very informative piece, I don't know how people cope these days without the aid of a scope ?

Keep em coming 8)
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Mini 2001. Airbag light on....

Postby Avdr » Thu Nov 15, 2012 7:39 am

Fantastic case study!

Presumably the case was that the K bus was in bad shape even before the valet, during which the airbag fault was recorded, and TPMS fault.

How did the modules communicate with the instruments, to show the faults on dash, are they 'hard wired' in the good old fashion way?
Avdr
Guru
Guru
 
Posts: 156
Joined: Sun Jan 08, 2012 9:25 am

Re: Mini 2001. Airbag light on....

Postby 4d » Thu Nov 15, 2012 8:06 pm

Nice work Darren, very interesting read.

I've had a similar case on an Octavia which had a Lin fault, using the method you used with 2 channels one either end of the wire nailed the fault straight away.

I am defiantly with Robski on how do people cope without a scope :D

Carl
4d
Newbie
 
Posts: 7
Joined: Wed Jan 28, 2009 5:44 pm

Re: Mini 2001. Airbag light on....

Postby AuthorMike » Fri Nov 16, 2012 11:58 am

I like it. Good work, thanks! :)
Mike Valentine
Technical Author @ Pico Technology UK
AuthorMike
Pico Staff Member
Pico Staff Member
 
Posts: 302
Joined: Mon Jan 31, 2011 11:22 am
Location: UK


Return to Case studies

Who is online

Users browsing this forum: No registered users and 0 guests