Pico leads PP718

Ask any questions relating to the PicoScope hardware or kit contents here.
If you have any questions prior to purchasing the kit post them here.

Pico leads PP718

Postby Karl winter(KarlW) » Fri Nov 02, 2012 4:02 am

Hi guys, First let me say that I am very happy with my Pico products. that said Is anyone else having a problem with leads coming dislodged from 4mm banana end part of leads?
I have been extra gentle with all my Pico products. The first one(TA128 yelllow) I thought could have been from me but now a second? I disconnect from test points tugging on 4mm tip gently and not the cable. I thought at first that I lost a channel because I was stabbing diesel injectors.thankfully that wasn't the case. The lead lost connection internal to 4mm end so I didn't see at first. I did repair them but I am wanting to get another set for road tests... and not sure what to purchase. Are the standard black TA000 more durable?

Thanks, Karl
User avatar
Karl winter(KarlW)
User
User
 
Posts: 13
Joined: Mon Sep 10, 2012 3:40 pm
Location: Somerville, Massachusetts

Re: Pico leads PP718

Postby Martyn » Fri Nov 02, 2012 7:44 am

Hi Karl,
This isn't something that we have heard of before, so please get in touch with me at support@picotech.com and I'll see what we can sort out for you.

Regards
Martyn
Technical Support Manager
Martyn
Pico Staff Member
Pico Staff Member
 
Posts: 177
Joined: Thu Aug 11, 2011 7:43 am
Location: Cambridgeshire

Re: Pico leads PP718

Postby Karl winter(KarlW) » Mon Nov 05, 2012 9:54 am

Martyn wrote:Hi Karl,
This isn't something that we have heard of before, so please get in touch with me at support@picotech.com and I'll see what we can sort out for you.

Regards

Thanks Martyn
Karl
User avatar
Karl winter(KarlW)
User
User
 
Posts: 13
Joined: Mon Sep 10, 2012 3:40 pm
Location: Somerville, Massachusetts


Return to Automotive kit hardware

Who is online

Users browsing this forum: No registered users and 0 guests