02 Clio smelly cat

Ask for and share advice on using the PicoScope kit to fix vehicles here.

02 Clio smelly cat

Postby Damian Mc Bride » Tue Sep 04, 2012 10:26 am

02clio oxygen sensor 1 and 2 smelly cat.psdata
(1.58 MiB) Downloaded 219 times
Hi i had a 02 clio 1.2 in today with a bad smell from the exhaust (like rotten eggs)
I scoped both o2 sensors all looks ok .
First part of capture is at 2750 rpm dropping to idle in second half.
I checked temp of cat at idle in 270 and out was 350*c
Anyone have any ideas on this, is a new cat likly to fix or am i missing something.
Also checked for fault codes none stored
Regards Damian
Last edited by Damian Mc Bride on Tue Sep 04, 2012 3:04 pm, edited 1 time in total.
Damian Mc Bride
User
User
 
Posts: 39
Joined: Sat Sep 03, 2011 8:50 am

Re: 02 Cio smelly cat

Postby AuthorMike » Tue Sep 04, 2012 10:39 am

Hi Damian,

Thanks for the post. Here are my thoughts...

The problem may not be the catalytic converter, the smell is actually from the cat working and doing its job, plus I believe if the cat was at fault, the engine light would be on (from the rear o2 sensor)?

I would try running a few tanks of higher octane fuel?


Mike
Mike Valentine
Technical Author @ Pico Technology UK
AuthorMike
Pico Staff Member
Pico Staff Member
 
Posts: 294
Joined: Mon Jan 31, 2011 11:22 am
Location: UK

Re: 02 Clio smelly cat

Postby Robski » Tue Sep 04, 2012 3:21 pm

Damian,

I made a CAT stink like that with a sensor simulator & altering the frequency of the switching of the upstream O2......

That was on a 1.2 Clio too.
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: 02 Clio smelly cat

Postby Damian Mc Bride » Tue Sep 04, 2012 8:43 pm

Thanks for replies guys.
Rob do you think a sensor can switch to quick i thought that if it switched once per second or quicker it was ok.
Customer came in saying they were talking to someone who had the same problem(not a clio) and lamda sensor fixed it.
I could not fault the sensor from that waveform unless someone can tell me otherwise.
Mike most of the petrol stations in this part of Ireland are Greatgass so not much choice here
Regards DamiaN
Damian Mc Bride
User
User
 
Posts: 39
Joined: Sat Sep 03, 2011 8:50 am

Re: 02 Clio smelly cat

Postby Robski » Wed Sep 05, 2012 4:31 pm

Damian

When i was messing about with the sensor simulator i had it running rough too at the same time it was stinking.

Check fuel trims etc & possibly disconnect the O2 sensor to see if it drops to a default map & stops stinking ?
User avatar
Robski
Advanced User
Advanced User
 
Posts: 602
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: 02 Clio smelly cat

Postby Damian Mc Bride » Wed Sep 05, 2012 8:44 pm

Rob the car has gone back now there was not much fuel in it so told the owner to try another brand of fuel to see if any difference.
Will post back if she comes back
Regards Damian
Damian Mc Bride
User
User
 
Posts: 39
Joined: Sat Sep 03, 2011 8:50 am

Re: 02 Clio smelly cat

Postby antthecat » Thu Sep 06, 2012 6:17 am

Hi, I've mot tested a few clios with smelly cats during the emission test, co low(less than 0.100), hc low and lambda 1.000, it might be a sign of a tired cat.

Older fiestas (k-m reg) used to stink like rotten eggs but once hot went through the test no problem.
antthecat
Advanced User
Advanced User
 
Posts: 70
Joined: Fri Dec 23, 2011 8:58 pm


Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests