Doesn't display frequency when testing a digital MAF

Ask any questions about using PicoScope Automotive software here.

Doesn't display frequency when testing a digital MAF

Postby GRUSS » Wed Mar 14, 2012 6:23 pm

Watched Paul's video last night ( excellent :D ) so today thought I would try it out. I went through the usual preset and could see the frequency scale set on channel A in the notes but when I pressed the space bar to go live the scale was set on voltage (100v) tried looking for the frequency option in the AC/DC coupling option but can't find it... :(

Forgot to say... It's a 4000 series automotive scope with latest software on.
GRUSS
Guru
Guru
 
Posts: 119
Joined: Tue Dec 27, 2011 11:16 pm

Re: Doesn't display frequency when testing a digital MAF

Postby Autonerdz » Wed Mar 14, 2012 7:23 pm

Gruss,

Sounds like the software was not communicating with the scope. You won't have the frequency select in the coupling dropdown unless the right scope is plugged in and communicating.

Just suggestion here though..

There is no reason I can think of why you would now ever want to graph frequency live. Why waste the channel? Use your channels to capture the MAF voltage and three other inputs. Then later, apply a frequency math channel to the desired channel. This can be done with a saved capture and the scope doesn't even have to be there. :wink:
Tom Roberts
(The Picotologist)
Autonerdz
User avatar
Autonerdz
Zen Master
Zen Master
 
Posts: 265
Joined: Wed Nov 20, 2002 4:19 pm
Location: Washington State USA

Re: Doesn't display frequency when testing a digital MAF

Postby Alan » Wed Mar 14, 2012 9:09 pm

Tom's diagnosis sounds right - unless PicoScope detects a PicoScope 4000 series at start up then it will not enable the frequency measurement.

With the PS4000 you have the choice of measuring frequency either using a maths channel (which can also be done with the older PS3000 series) or to measure in hardware. The hardware method does give better resolution than the maths channel method, but both work. If using the maths channel make sure you have lots of memory enabled as this will improve the resolution.

As with the method of displaying frequency, whether you do it live or after capture is personal preference. I very rarely disagree with Tom but when doing a snap throttle test I like to see the waveform live to make sure I have captured it OK in real time. As so often there is no right or wrong so try both approaches and see which is best for you.
Alan
Pico Staff Member
Pico Staff Member
 
Posts: 234
Joined: Thu May 25, 2006 8:02 am

Re: Doesn't display frequency when testing a digital MAF

Postby GRUSS » Fri Mar 23, 2012 9:18 am

This was a error on my behalf. I have/had a bad habbit of starting the pico software before Connecting the scope. It doesn't seem to like it this way. Works fine if I connect the scope first though. I've learnt!
GRUSS
Guru
Guru
 
Posts: 119
Joined: Tue Dec 27, 2011 11:16 pm


Return to PicoScope 6 Automotive software

Who is online

Users browsing this forum: No registered users and 0 guests