Automotive kit test leads ?

Ask any questions relating to the PicoScope hardware or kit contents here.
If you have any questions prior to purchasing the kit post them here.
Post Reply
User avatar
Robski
Advanced User
Advanced User
Posts: 597
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Automotive kit test leads ?

Post by Robski » Fri Jan 28, 2011 3:51 pm

Hi

Can anybody tell me the input impedence of the four test leads that come with a four channel kit please ?

Thanks .

User avatar
Robski
Advanced User
Advanced User
Posts: 597
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Automotive kit test leads ?

Post by Robski » Fri Jan 28, 2011 6:25 pm

just to add i could do with knowing this over the weekend.

Thanks

Alan
Pico Staff Member
Pico Staff Member
Posts: 255
Joined: Thu May 25, 2006 8:02 am

Re: Automotive kit test leads ?

Post by Alan » Wed Feb 02, 2011 7:20 pm

Hi,

The input impedance of the PicoScope, is (like all scopes) 1 Mega ohm.

The standard test leads are well, just leads (ie just low impedance wire / shielded co-ax cable). When plugged in to the scope the impedance at the tips of the leads will be that of the scope - ie 1 M ohm.

Regards
Alan

User avatar
Robski
Advanced User
Advanced User
Posts: 597
Joined: Tue Sep 14, 2010 6:36 pm
Location: Yorkshire

Re: Automotive kit test leads ?

Post by Robski » Wed Feb 02, 2011 8:19 pm

alan

thank you for the reply that was the info i was after,however it was for the use of a Blue-point CTB & i saw this in the instructions as a warning.

Does not matter now as i have sent it back as it was faulty & ordered one from yourselves :wink:

Rob.

Post Reply