Problem getting rpm signal from vehicles.

Ask questions relating specifically to the PicoDiagnostics NVH equipment and software here.
Post Reply
barrieautos
Newbie
Posts: 3
Joined: Fri Jun 14, 2019 3:05 am

Problem getting rpm signal from vehicles.

Post by barrieautos »

Hi,

We bought an NVH kit some time ago and never had success getting the rpm signal. We have tried our existing J2534 tools (Autel and GM MDI-2) as well as an ELM327 cable.
We have now bought the Mongoose Pro ISO/CAN2 cable and are still having no success.

I found this other thread: viewtopic.php?t=21869
so will answer Steve's questions there.

The drivers for the cable are installed. I can talk to a vehicle (tried it on a Hyundai) and extract the VIN etc using the Drew Tech Toolbox. The Mongoose shows up in device manager, which reports it is working correctly.

I'm not sure what is meant by VM software. I am not using a virtual machine.

When attempting to connect it does not name the Mongoose, there is a red cross and a message "Connecting to scan tool". After a while there is another message saying that maybe the drivers are not installed or a firewall is blocking connection. This is a brand new standalone laptop so I don't think there is a firewall involved.

I was unable to locate the folder with the long alphanumeric name (looking in C:/Program Files (x86) / Pico Technology / PicoDiagnostics.

What next?

Thanks,
Ron

User avatar
PicoKev
TwoWaves
TwoWaves
Posts: 238
Joined: Thu Apr 05, 2012 9:16 am

Re: Problem getting rpm signal from vehicles.

Post by PicoKev »

"I'm not sure what is meant by VM software. I am not using a virtual machine."
In this instance I suspect VM = Vehicle Manufacturers. :)

Steve Smith
Pico Staff Member
Pico Staff Member
Posts: 1604
Joined: Sun Aug 25, 2013 7:22 am

Re: Problem getting rpm signal from vehicles.

Post by Steve Smith »

Hello Ron and thank you for the post

The Mongoose Pro ISO/CAN2 should allow seamless connection to ICE vehicles with NVH

To which vehicle are we trying to connect?

Which version of NVH are you using?

Sorry, when we refer to VM we are describing Vehicle Manufacturer items such as software/hardware

The fact that you can use your Mongoose Pro ISO/CAN2 to obtain VIN via the Drew Tech Toolbox suggests it is installed correctly and “Activated”

The following concerns me “When attempting to connect it does not name the Mongoose”

This suggest our NVH software cannot locate the Mongoose Pro ISO/CAN2 within the PassThru Registry

Below we can see all the PassThruSupport hardware installed on my laptop with Mongoose-Plus ISO3 listed
1
1
Could you type “Registry editor” in your window search bar and check for the presence of your Mongoose Pro ISO/CAN2 within Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PassThruSupport.04.04\

Please do not make any changes in the registry, just check for the presence of your Mongoose

If present then great, if not, can you check for later software/drivers/updates for your Mongoose Pro ISO/CAN2

Perhaps uninstall and reinstall the Mongoose Pro ISO/CAN2 software

In order to support you further, could you provide a trace file of a failed attempt to connect to a vehicle with NVH

Please open NVH and select Enable OBD logging (see below)
2
2
Click the large NVH button and “Start a new test”

Select the relevant RPM selection for the vehicle under test (J2534)
3
3
Click on "Next" and wait for the error message of “Failed to connect” (This may take approx. 1 minute)

At this point, close the software (do not reopen) and locate the Trace file as described in the video here. (The video also describes how to find a hidden Trace file)

https://drive.google.com/file/d/182O9eq ... sp=sharing

Could you send this over when possible, you can send this to support@picotech.com if you prefer

I hope this helps,

Take care……Steve

barrieautos
Newbie
Posts: 3
Joined: Fri Jun 14, 2019 3:05 am

Re: Problem getting rpm signal from vehicles.

Post by barrieautos »

Thanks for your help Steve.

The Mongoose shows up in the pass through registry.

I am using Version 1.16.144 build 0.

I have sent the trace file.

Ron

Post Reply