Canbus decoding

Ask any questions about using the new PicoScope 7 Automotive software here.
Post Reply
User avatar
Frank0705
Newbie
Posts: 5
Joined: Mon Nov 09, 2020 5:48 pm

Canbus decoding

Post by Frank0705 »

Hello everyone,

I have a question about the canbus decoding option, and in specific the making of a template. I was identifying the ID's from the engine ECU and the ABS module by disconnecting these from the network and capturing the data. I used the Practical Pico: CAN bus diagnostics and serial data decoding VIDEO to help me identify the different ID's so I could make a template. The video explained this really good and making a template is not really hard. But when I tried this template on PicoScope 7 it would say "no columns found", so I tried it on PicoScope 6 and there it worked without a problem. Is this a known problem? Or are there different steps to be taken to make it work?

Greetings Frank

Steve Smith
Pico Staff Member
Pico Staff Member
Posts: 1054
Joined: Sun Aug 25, 2013 7:22 am

Re: Canbus decoding

Post by Steve Smith »

Hello Frank, thank you for the post

I need to l clarify a few steps if I may?

Did you initially create a link file (Create Template) when clicking the "Link" button in the serial decode table of PS6?
Image 1
Image 1
Once created did you then add your ID's and ID descriptions?

Once complete could you Open this Template from within the serial decode table of PS6 and read your ID descriptions?

When using PS7 and clicking on "Data to text" in the serial decode table and selecting your created link file, is this where you receive the error message?
Image 2
Image 2
Sorry for all the questions Frank and forgive any misinterpretation of this concern

Take care.....Steve

User avatar
Frank0705
Newbie
Posts: 5
Joined: Mon Nov 09, 2020 5:48 pm

Re: Canbus decoding

Post by Frank0705 »

Hello

The steps you described are the exact steps I took to make the template. I made the template by clicking the link button and saving a template. Then I needed to start Excl and I could open this template. Where I could fill the template with te gathered data. After saving and closing Excel I simply openend the file in Pico6. When I tried to open the same file in Pico7 it would give the error. But when I look at your capture is says "LINK PS6" on my screen, I only get open and create template in the same menu.

I included the waveform and the template, perhaps it helps?

No need to feel sorry for the questions, I'm glad you are taking the time to help me.
Attachments
20210410-0001test.csv
(1005 Bytes) Downloaded 15 times
CAN ori.2.psdata
(11.96 MiB) Downloaded 15 times

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 292
Joined: Tue May 16, 2017 1:02 pm

Re: Canbus decoding

Post by ben.martins »

Hello Frank,

I've recreated the template from within PS7 and have attached here -
Forum user.csv
(1005 Bytes) Downloaded 17 times

When I looked at the template you had uploaded there was something wrong with the layout which is why it would never work. I'm not sure what would have caused this to be honest.
CAN DATA 2 TXT.png
I am using the latest PS7 version from the website which is now 7.0.70.8002. I created the template from here and then added the ID's and the description as Steve mentioned.

Let us know how you get on and if the Link file I've created works for you.

Kind regards

Ben

User avatar
Frank0705
Newbie
Posts: 5
Joined: Mon Nov 09, 2020 5:48 pm

Re: Canbus decoding

Post by Frank0705 »

Hello Ben,

I tried your template and it works perfectly! The layout in your file is indeed different than mine, it's strange that PICO6 accepts it and PICO7 does not. But I probably did something wrong, decoding is still new to me and a new skill is never learned in one attempt. I'm going to do some decoding in the weekend and just try again, using your file as a reference.

For now, thank you for your time and I will let you know how I get on.

Frank

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 292
Joined: Tue May 16, 2017 1:02 pm

Re: Canbus decoding

Post by ben.martins »

Hi Frank,

I'm glad it worked. Not quite sure what happened with the template you had created but hopefully you have something work with now.

Enjoy the decoding journey!

Kind regards

Ben

Post Reply