BMW E66 ENGINE MISFIRE

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.
Post Reply
chad66
OneWave
OneWave
Posts: 13
Joined: Thu Jun 25, 2020 12:10 pm

BMW E66 ENGINE MISFIRE

Post by chad66 »

Hello again,

Need some help to identify a misfire on a BMW E66 N62 engine.... To explain a bit of the problem here goes...Cold engine have a misfire on cyl 6,7 and sometimes 3, persistent on cyl 6 & 7. However, after awhile once the engine warms up no more misfire... Initially found a lot of air leaks and corrected the issue... Have swapped coils and plugs but to no avail... have attached some in cyl waveforms for cyl 2 and 6... would appreciate if someone could take a look at them and see if there is anything there I am unable to identify or suggest any additional tests/ checks that i can try...

Thanks
Attachments
incyl 6- cranking.psdata
(211.57 KiB) Downloaded 74 times
INCYL 6 AND COIL 7.psdata
(28.92 MiB) Downloaded 67 times
incyl 2- cranking.psdata
(180.71 KiB) Downloaded 64 times
IN CYL 7 AND COIL 6.psdata
(29.05 MiB) Downloaded 66 times
IN CYL 7 & COIL 6.pdf
(1.02 MiB) Downloaded 61 times
in cyl 6 engine running.psdata
(544.16 KiB) Downloaded 62 times
in cyl 2 engine running and snap throttle.psdata
(58.09 KiB) Downloaded 60 times
FIRST LOOK AND CYL 1.psdata
(3.23 MiB) Downloaded 62 times
CYL 1 COIL & CRANK SENSOR.psdata
(25.18 MiB) Downloaded 63 times
COIL 2 YELL0W TRACE AND COIL 6 RED TRACE.pdf
(656.17 KiB) Downloaded 61 times

Post Reply