1996 Civic LXO - losing power uphill, stalls once hot

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

1996 Civic LXO - losing power uphill, stalls once hot

Postby Civic96 » Thu Apr 05, 2018 9:15 am

I have a Manual 96 Civic at 281,000 miles. I don't want to throw too many parts at it, and need some knowledge prior to going to mechanics. Each one has a different diagnosis so far.

For 3 weeks the Civic had been losing power while on the freeway. Once the engine was warmed up on the freeway, if it was a slight incline, I had to shift down to keep the speed at 60.

The spark plugs/wires/cap-rotor have been replaced. I can start the car and drive side streets successfully....although very weak on hills. Once the car is warmed up, it dies when I come to a stop. I can restart the car, although if I drive it too long/hot - it is difficult to start the car, unless it's on a downhill. I do get a slight odor (maybe exhaust) once the car is hot. Possibly, My radiator fan is out too...

Would this be an exhaust, sensor, Intake Air Valve issue? Any suggestions on what I should check first?
Civic96
Newbie
 
Posts: 1
Joined: Thu Apr 05, 2018 8:45 am

Re: 1996 Civic LXO - losing power uphill, stalls once hot

Postby kona » Fri Apr 06, 2018 10:07 am

Civic96 wrote:I have a Manual 96 Civic at 281,000 miles.

.......... - it is difficult to start the car, unless it's on a downhill.............

Any suggestions on what I should check first?


HI,

You do not give any specific measurement ... :?: :?: :?:

Based on your description: - Measure the fuel pressure.
kona
OneWave
OneWave
 
Posts: 34
Joined: Thu Feb 22, 2018 10:14 pm

Re: 1996 Civic LXO - losing power uphill, stalls once hot

Postby liviu2004 » Fri Apr 06, 2018 1:45 pm

Sounds like fuel flow delivery problems or plugged exhaust. Fuel filter if fitted ever changed?
I would do in cylinder pressure waveform test, fuel pump current and pressure test.
What scope do you have?
liviu2004
TwoWaves
TwoWaves
 
Posts: 117
Joined: Sat Mar 19, 2016 10:23 am
Location: Netherlands

Re: 1996 Civic LXO - losing power uphill, stalls once hot

Postby Technician » Fri Apr 06, 2018 9:31 pm

liviu2004 wrote:Sounds like fuel flow delivery problems or plugged exhaust. Fuel filter if fitted ever changed?
I would do in cylinder pressure waveform test, fuel pump current and pressure test.
What scope do you have?


This thread comes across as a person who has been to some garages and had different opinions and no solution to the problem, but is asking what is wrong with the car before the person takes it to another garage for diagnosis/repair.

I don't think scopes are even a thought at this time! :)
Technician
TwoWaves
TwoWaves
 
Posts: 363
Joined: Thu Apr 24, 2014 10:32 pm


Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 0 guests