Odd COP secondary ignition waveform

Ask for and share advice on using the PicoScope kit to fix vehicles here.
Post Reply
eric989
OneWave
OneWave
Posts: 33
Joined: Fri Apr 16, 2010 6:53 am
Location: Hongke China
Contact:

Odd COP secondary ignition waveform

Post by eric989 » Mon Jan 29, 2018 7:13 am

Hi,

Can somebody comment the waveform below? It looked very odd, the Dwell Period is Positive and the Burn Time is Negetive. It's from a Hyundai Sonata, the waveform from all 4 cylinders are same, and the vechicle vibrates at idle.

Thanks,
Eric
1.jpg

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 100
Joined: Tue May 16, 2017 1:02 pm

Re: Odd COP secondary ignition waveform

Post by ben.martins » Mon Jan 29, 2018 8:59 am

Hello Eric,

From the image you've sent it would appear the waveform is inverted. This happens as a result of a negatively fired ignition system. What we have to do is fairly straight forward and just adjust the probe to secondary ignition probe inverted. This should now flip your image and display it a way we are more used to.

I hope this helps and if you need any further assistance please get in touch.

Kind regards

Ben
Attachments
Secondary ignition pick up.jpg

liviu2004
TwoWaves
TwoWaves
Posts: 118
Joined: Sat Mar 19, 2016 8:23 am
Location: Netherlands

Re: Odd COP secondary ignition waveform

Post by liviu2004 » Mon Jan 29, 2018 4:07 pm

I believe I see also AC coupling instead of DC?

eric989
OneWave
OneWave
Posts: 33
Joined: Fri Apr 16, 2010 6:53 am
Location: Hongke China
Contact:

Re: Odd COP secondary ignition waveform

Post by eric989 » Wed Jan 31, 2018 9:17 am

Hi Ben,

You are right. Yes, we need to invert the waveform. I was misunderstood by the user before. Here I got the psdata from him. The waveform looks normal. Thanks.

And thank you Liviu2004.

Eric
Inverted.png
Attachments
Odd secondary waveform.psdata
(713.99 KiB) Downloaded 87 times

ben.martins
Pico Staff Member
Pico Staff Member
Posts: 100
Joined: Tue May 16, 2017 1:02 pm

Re: Odd COP secondary ignition waveform

Post by ben.martins » Wed Jan 31, 2018 11:03 am

Hi Eric,

Not a problem and glad you got it sorted!

If you need any further assistance do get in touch.

Kind regards

Ben

Post Reply