Toyota Premio STFT always shows -100%

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.
Post Reply
MasudRM
OneWave
OneWave
Posts: 14
Joined: Sun Aug 07, 2016 8:25 am
Location: Bangladesh

Toyota Premio STFT always shows -100%

Post by MasudRM » Sun Dec 03, 2017 8:37 am

Hello guys, 2 weeks ago we serviced 2012 Toyota Premio's Fuel and Intake system including Throttle and also open up the intake manifold and cleaned up. The problem was rough idling. After the service rough idling solved. But after that P0171 started coming on, we even replaced the MAF sensor with a known good one.
The vehicle came back today morning with the MIL on, and guess what it was P0171, with P0401. Also when i checked for data list, the STFT shows negative 100%, and doesn't changes.
Any suggestions...?
Thanks....

Technician
TwoWaves
TwoWaves
Posts: 377
Joined: Thu Apr 24, 2014 8:32 pm

Re: Toyota Premio STFT always shows -100%

Post by Technician » Sun Dec 03, 2017 5:56 pm

First off I'd be inclined to look over the previous work completed to ensure all is in order. The minus 100% STFT tells me that the PCM is subtracting the maximum amount of fuel possible. The P0171 code I think is referring to an air leak, check the hoses, gaskets, vacuum pipes etc. The code P0401 is referring to the EGR insufficient flow I think, but I'd concentrate first of all by going over what has previously been carried out. When you are happy that all previous work is in order, put the scope on the H02 sensor and check operation, also check the operation of the mass air flow sensor.

MasudRM
OneWave
OneWave
Posts: 14
Joined: Sun Aug 07, 2016 8:25 am
Location: Bangladesh

Re: Toyota Premio STFT always shows -100%

Post by MasudRM » Tue Dec 12, 2017 5:38 am

Thank You..

Post Reply