Reference waverforms trouble

Ask any questions about using PicoScope Automotive software here.

Reference waverforms trouble

Postby liviu2004 » Sat Nov 25, 2017 9:01 pm

I am official lost with the reference waveforms.
I have a good pstdata file. I managed somehow to make 3 reference waveforms. After I Duplicate about 3-4 times each, cause it just did not wanted to stay Saved. :shock:

Question 1: Why do they show in Loaded and why there is nothing in Library?
Question 2: How do I put them in Library?
Question 3: when I select one waveform, why the button Export is greyed out?
Question 4: how on earth I load these reference waveforms in another pstdata file? Nothing is shown in Library or Loaded?
Question 5: how do I get 3 reference waveforms in another pstdata file and keep them on the same time as they were in the initial capture?
liviu2004
TwoWaves
TwoWaves
 
Posts: 91
Joined: Sat Mar 19, 2016 10:23 am
Location: Netherlands

Re: Reference waverforms trouble

Postby ben.martins » Mon Nov 27, 2017 12:11 pm

Hi Liviu,

Really not a problem and I'm sure we can help you get to grips with them.

I think it's easier if we just answer your questions one at a time!

Question 1: Why do they show in Loaded and why there is nothing in Library?


Any reference waveform in the loaded section have been saved with the original PSDATA file and remain with that file. The library section is all the reference waveforms you have that are stored on your local hard drive.

Question 2: How do I put them in Library?


To add any of these to your library you will need to Export them to your computer. There are couple of ways you can do this. Firstly if you were to open the reference waveform box from the Tools menu, select one of the references in the loaded section and double click. This should then move the reference from the loaded section to the library. I've attached a video on how to do this.
Reference Waveform Creation.mp4
(2.41 MiB) Downloaded 57 times


The other option is to Export the individual waveforms;. Again, click Tools and reference waveforms. Highlight the reference you wish to export by left clicking and then click Export. This will now give the option to save the reference waveform to your computer. Type in a name that is relevant and click Save. Nothing will really change now until you close PicoScope and then re-open as this will store any settings we have just changed. Open PicoScope and then go back to the reference waveform tab. Now click the Import button, find your reference waveform and click Open. You should now see the reference waveform in your Library. Again, there is a short video here which will hopefully explain it a little easier!
Reference Waveform Creation with Export.mp4
(4.5 MiB) Downloaded 50 times


Question 3: when I select one waveform, why the button Export is greyed out?


This I'm not entirely sure of. I've not had this problem before. Would you be able to upload the PSDATA file you are having concerns with and I will take a look.

Question 4: how on earth I load these reference waveforms in another pstdata file? Nothing is shown in Library or Loaded?

Question 5: how do I get 3 reference waveforms in another pstdata file and keep them on the same time as they were in the initial capture?



Hopefully the videos above will help you load these waveforms into another PSDATA file but if there is anything else I can do to help then please get in touch.

Kind regards

Ben
ben.martins
Pico Staff Member
Pico Staff Member
 
Posts: 80
Joined: Tue May 16, 2017 3:02 pm

Re: Reference waverforms trouble

Postby liviu2004 » Mon Jan 15, 2018 8:06 pm

Ben, I've might have not reacted yet, but I've read your post. So your efforts are not for nothing.

When I say why the Export button is greyed out, this is actually for all psdata files. Here what might go different. I never double clicked a waveform because I thought just selecting one would be sufficient. So if I now understand correcty, I first have to Load it then Export it.

Maybe is just me not reading the user manual. :oops:

I start playing with this.
Last edited by liviu2004 on Mon Jan 15, 2018 8:23 pm, edited 1 time in total.
liviu2004
TwoWaves
TwoWaves
 
Posts: 91
Joined: Sat Mar 19, 2016 10:23 am
Location: Netherlands

Re: Reference waverforms trouble

Postby liviu2004 » Mon Jan 15, 2018 8:22 pm

Here we go, my first pain free reference waveform. Anyone likes the injector voltage waveform? :D

reference waveform.png
liviu2004
TwoWaves
TwoWaves
 
Posts: 91
Joined: Sat Mar 19, 2016 10:23 am
Location: Netherlands

Re: Reference waverforms trouble

Postby Tronic » Tue Jan 16, 2018 5:35 pm

An excellent and crystal clear reference waveform! :D Well done liviu2004! I have done a few when needed, but it took me a few tests before I was satisfied with the result.
User avatar
Tronic
TwoWaves
TwoWaves
 
Posts: 81
Joined: Fri Oct 23, 2015 4:43 pm
Location: Sweden


Return to PicoScope 6 Automotive software

Who is online

Users browsing this forum: No registered users and 1 guest