2000 Grand Prix GTP SC (L67) - erratic idle and stall

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

2000 Grand Prix GTP SC (L67) - erratic idle and stall

Postby regval48 » Tue Oct 31, 2017 6:18 am

GM 3800 supercharged year 2000 Pontiac Grand Prix GTP. Engine starts and runs but struggles to keep a stable idle speed, RPM varying from 1500 down to 600 and back up until gradually stalling out. It will re-start with no problem and engine can be kept running with throttle assist but still has an audible short stall (drop in RPM). Occasionally P0300 code (random misfire).
Scan data shows active O2 for upstream and downstream, St fuel trim in closed loop fuel status no more than +4 and no lower than -8, LT trim average about -8. MAP and MAF signals look normal using a Tektronix 2213 0-scope.
Original problem was thought to be fuel pump/pressure. Found fuel pump relay (high speed) bad as well as speed resistor. (This engine uses a 2 speed pump, changing speed by inserting a resistor in series between fuel pump and supply voltage to drop voltage to pump)

Fuel pressure 43 to 48PSI with original symptom. During testing, misfire codes increased with codes P0301, p0304 and P0300.
Replaced ICM (ignition control module) and all three coils with new parts. Now, only random P0300 misifire with engine stall.
Parts replaced: IAC, MAF, spark plugs, wires, Fuel Pressure regulator (FPR), fuel pump (now reads 52 PSI) and lower intake gasket due to small vac leak (found with smoke test) and gasket for supercharger. Throttle body and EGR valve and ports cleaned.
Crank and Cam sensor waveforms appear normal amplitude on o-scope, nice square waves with no apparent drop-outs.
Grounds on ICM and PCM are all good, voltage drops test <0.1 vdc. Sensor reference voltages (5v) reads 4.8V and no noise.
I don't know what to expect for Ignition timing values while running, but the scan tool (ACTRON Elite) shows timing varying from 5 deg to 21 degrees while the engine attempts to idle. Maybe normal, maybe not.
Any suggestions are welcome.... I'm at a loss (I'm not a ASE mechanic, just a hobbyist, been working on cars here and there for a little over 50 years, so I'm not a novice...thanks in advance.
regval48
Newbie
 
Posts: 2
Joined: Tue Oct 31, 2017 5:42 am

Re: 2000 Grand Prix GTP SC (L67) - erratic idle and stall

Postby regval48 » Sat Nov 04, 2017 6:09 pm

FIXED.
In case anyone is interested in this reported problem....
The problem was with the harmonic balancer, specifically with the steel rings attached to the rear of the balancer that have "teeth" that are used to trigger the CPK sensor. There were two missing screws (of 4) and the remaining hold down screws for these rings were loose, allowing the rings to move around. The screw holes had elongated due to wear. The harmonic balancer was replaced. The CKP sensor tested fine and was not replaced. The engine started and ran smooth, idle stable, no stalling, fuel trims within spec, etc. If I had access to one of those nice PICO scopes, I'm sure I would have been able to observe the CKP signal shifting around.
regval48
Newbie
 
Posts: 2
Joined: Tue Oct 31, 2017 5:42 am


Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 0 guests