Mazda Eunos / Mx5 16v

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

Mazda Eunos / Mx5 16v

Postby STC » Thu Aug 03, 2017 12:33 pm

This is a car First Used in Japan then exported to the UK. It was first registered here in 1994 but may actually be older, lots of dodgy registrations occurred in those days.
It is a Eunos and not an MX5, there may be some differences.

Problem I have is a lack of product knowledge, wiring diagrams, technical information, function descriptions. The car, when warm will cough splutter, pop through the exhaust. I can make it do that standing still without the need to drive it, although it is worse on the road. It smells a little rich, tail pipe is sooty and matt black but not terrible. Temperature sensor is plausible.

It has a coil pack with 2 x 4 pin Connectors. Plus, Minus, Trigger & Feedback I'm guessing on each.
At the back of the Exhaust cam is a Optocoupler / Cam Position Sensor that has 4 wires - Plus Minus and 2x 5v Square Signals.
Strange observation is that the RPM needle does not move when it runs right but comes to life when it faulters ???
I have looked at Flash codes, all I get is Code 17 - O2S1. Some one has cut it and the Catalyst out.

Here I have it running right
MX5 Coil Injectors Good.jpg

Here it is faultering but the Cam Signals are not dropping out
MX5 Cams  Coil Injectors.jpg

Here it is with the MAF Unplugged.
MX5 Coil Injectors Maf Off Running Bad.jpg


File below is with the Plugged in and it is clearly dropping out
Mazda MX55 Coil Injector MAF Bad.psdata
(741.35 KiB) Downloaded 28 times


In that waveform you can se it run ok and then I stab the throttle several times to make it go bad and then hold it in the bad state.

Do I have a Bad / Shorted Maf here is something going on in the wiring or ECU, thinking about the RPM needle as it faulters ??? It does it alays with the MAF off, never seen that before ???

The other thing to note is the Injector (Green) Current when it fails. On one of the captures I think I have the Amp Clamp set to 60a but the software thinks it is in 20a mode.
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: Mazda Eunos / Mx5 16v

Postby STC » Tue Aug 15, 2017 9:44 pm

I have got some schematics for this now and fitted and oxygen sensor.

I have good information that tells me the tachograph signal is a 12v Output from Both coils on the same wire that is pulled to ground each time a coil is fired. My signal is 7v pulled to ground so that will explain the erratic tacho fault. Same wire runs to the ECU as Misfire Detection I guess for now. I will need to establish which of the three - the tacho, ECU or Coils should be providing the missing 12v for the Coils to pull it to ground.

It is running at 12% CO so very rich and the O2 does react and go lean on overrun. I have blocked EVAP, Fuel pressure is not high, and looked at Injector durations trying to establish a reason for this but to no avail. The Temp sensor is very plausible and the cooling fans are doing their thing.

Here is a waveform of secondary ignition events where from Idle I am stabbing the throttle and towards the end of the capture you can see it go beserk.



Some strange things going on there, lack of spark lines and lots more. I am wondering if the spark is occurring outside the cylinder or it is losing compression.

Would appreciate some help to make some sense of this. Had it wrapped round my neck for a few weeks now.

thanks
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: Mazda Eunos / Mx5 16v

Postby PicoKev » Tue Aug 15, 2017 11:11 pm

Any Help?
Attachments
For STC.PNG
PicoKev
TwoWaves
TwoWaves
 
Posts: 92
Joined: Thu Apr 05, 2012 11:16 am

Re: Mazda Eunos / Mx5 16v

Postby STC » Tue Aug 15, 2017 11:15 pm

Yes Kev

And I have the diagrams

I would appreciate an analysis on the secondary waveforms
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: Mazda Eunos / Mx5 16v

Postby speck » Wed Sep 20, 2017 4:43 am

Hi STC
Ever solved the problem with that Mazda ?
speck
Newbie
 
Posts: 6
Joined: Sun Mar 25, 2012 7:20 am

Re: Mazda Eunos / Mx5 16v

Postby STC » Sun Sep 24, 2017 10:13 pm

Still got it wrapped around my neck. Running 12% CO - Coughing and spluttering.

It has been been mapped, de catted and god knows what else I have since discovered.
.
I have thrown new plugs, coil packs, Injectors at it so far. Come Tuesday I will push it out on the Road. The Parking fine should write it off with some luck.

it and the owner are ripe to be scrapped - Local Bylaws permitting !
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am


Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 0 guests