Feature Request - Capture Scope Model

Ask any questions about using PicoScope Automotive software here.

Feature Request - Capture Scope Model

Postby FioranoCars » Tue Aug 01, 2017 1:31 pm

Hi Pico Dev Team

Any chance you can include the ORIGINAL capturing scope model within the "Properties" page. It's not displayed right now, and for post capture checking which scope was used it's quite good to know. (noise levels etc)

I'm sure it's in the file.

I "think" it gets lost too if you save a waveform via the Demo device, so maintaining the original scope as a value would be important for those of us who have more than 1 model and analyse off line often!

thanks
Richard Lukins
User avatar
FioranoCars
TwoWaves
TwoWaves
 
Posts: 377
Joined: Thu Dec 13, 2012 1:26 pm
Location: London, UK

Re: Feature Request - Capture Scope Model

Postby AuthorMike » Wed Aug 02, 2017 10:31 am

Hi Richard,

I currently have PicoScope 6.12.7 installed (our latest software) and this feature already exists. Under "Views>Properties" I can see the software version that the file was saved with, and the PicoScope model.

Can you confirm you do not see this information?
Mike Valentine
Technical Author @ Pico Technology UK
AuthorMike
Pico Staff Member
Pico Staff Member
 
Posts: 325
Joined: Mon Jan 31, 2011 1:22 pm
Location: UK

Re: Feature Request - Capture Scope Model

Postby FioranoCars » Wed Aug 02, 2017 10:49 am

Hi Mike.

Using 6.12.7.2724

Sadly it appears, but under "saved with", as soon as you work off-line (no real scope attached) and re-save the file, that information is lost and becomes "demo" :?

I was convinced that even opening the file changed it, but that might have been on an older version, not sure as away from my desk with that PC.

In terms of software version, from your (and our own too) point of view both the capture version and saved versions are probably relevant (even a list of them!), whereas for device, surely the capture model/serial are all that's of importance, any re-saving is not going to use the features of any scope attached?

PS I'm currently working from a "Virgin Broadband" location, and getting massive amounts of "re-captcha", which is often dropping the post contents even if successful first attempt! Is there nothing you can do to improve this? :twisted: :twisted:

Surely once the re-captcha has been passed, all preview requests can be passed, and only a trigger set for multiple postings in quick succession or something?

thanks

Richard Lukins
User avatar
FioranoCars
TwoWaves
TwoWaves
 
Posts: 377
Joined: Thu Dec 13, 2012 1:26 pm
Location: London, UK

Re: Feature Request - Capture Scope Model

Postby AuthorMike » Wed Aug 02, 2017 1:09 pm

FioranoCars wrote:Hi Mike.

Using 6.12.7.2724

Sadly it appears, but under "saved with", as soon as you work off-line (no real scope attached) and re-save the file, that information is lost and becomes "demo" :?

I was convinced that even opening the file changed it, but that might have been on an older version, not sure as away from my desk with that PC.

In terms of software version, from your (and our own too) point of view both the capture version and saved versions are probably relevant (even a list of them!), whereas for device, surely the capture model/serial are all that's of importance, any re-saving is not going to use the features of any scope attached?


Ah I see. So you are re-saving the file without a scope attached, and that is then changing the device to demo. I'll speak to the software team on this, as I see your point. Post-capture analysis may well take place on a machine without a scope, and then be saved so I can see why this info would be useful.

In addition I suspect the filename would need to be kept the same. I'll put it through as an improvement/bug fix.

FioranoCars wrote:I'm currently working from a "Virgin Broadband" location, and getting massive amounts of "re-captcha", which is often dropping the post contents even if successful first attempt! Is there nothing you can do to improve this? :twisted: :twisted:

Surely once the re-captcha has been passed, all preview requests can be passed, and only a trigger set for multiple postings in quick succession or something?

thanks

Richard Lukins


I appreciate your issues here regarding the captcha, and I believe an upgrade to the forum is being looked at, but I can't say what stage it is at. What I can suggest in this instance is it may be your using of hyperlinks, as the captcha technology looks for hyperlink coding etc as a possible spam user. I realise this is frustrating, but if you could refrain from using those hyperlinks at the bottom of your posts, it should help (and keeps the forum a bit cleaner, hence the lack of signatures).

Thanks,
Mike Valentine
Technical Author @ Pico Technology UK
AuthorMike
Pico Staff Member
Pico Staff Member
 
Posts: 325
Joined: Mon Jan 31, 2011 1:22 pm
Location: UK

Re: Feature Request - Capture Scope Model

Postby STC » Tue Aug 15, 2017 3:29 am

Open Pico Software - Pico not connected >

Would you Like to use demo mode > Answer NO

Then open saved Psdata files and play and save to your hearts content.
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: Feature Request - Capture Scope Model

Postby FioranoCars » Tue Aug 15, 2017 11:44 am

Hi
Sadly not sure what version of Pico you are using, but I have no option to say no to "demo" device if I open the software.

even unticking the preferences of "remember last device" fails to give me a prompt!?

However if utilising a Pico Bug (unintended consequence/action of the software!) - close all pico instances, unplug any scopes, find a pico file (.psdata) and double click it ... no device attached ... but, the bug ... this bug has a massive issue, you can't set or change channels options, in fact you can't even see them!! see below:
pico no options.png
No settings even visible


Verse open with "demo device" select all settings and options are visible:
pico features live.png
Features visible if demo device selected


Working offline without the ability to see what settings were used let alone change things, is not going to work! It's a bug (undesired consequence/action/feature) and should be squished, at least acknowledged and added to the development list. (Hello ?)

Maybe you are using a version that behaves differently than the current release?

Best
Richard
User avatar
FioranoCars
TwoWaves
TwoWaves
 
Posts: 377
Joined: Thu Dec 13, 2012 1:26 pm
Location: London, UK

Re: Feature Request - Capture Scope Model

Postby STC » Tue Aug 15, 2017 1:02 pm

Sadly not sure what version of Pico you are using, but I have no option to say no to "demo" device if I open the software.


It is irrelevant which version of software I am using, the function is there on both the current Stable & Beta releases. Has been on earlier versions for I don't know how long! 5 years at least IIRC !

Capture delete.JPG


I think in the past some one has clicked "Yes" to use the demo version and also checked the box to Remember option and perform it on start up"
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: Feature Request - Capture Scope Model

Postby AuthorMike » Tue Aug 15, 2017 1:09 pm

STC wrote:I think in the past some one has clicked "Yes" to use the demo version and also checked the box to Remember option and perform it on start up"


I agree STC.

To resolve this, click: "Tools > Preferences"

Under the General tab the large button at the top states "Reset 'Don't show this again' dialogs".

Click "OK"

Restart the software and you should see the demo device dialog box.
Mike Valentine
Technical Author @ Pico Technology UK
AuthorMike
Pico Staff Member
Pico Staff Member
 
Posts: 325
Joined: Mon Jan 31, 2011 1:22 pm
Location: UK

Re: Feature Request - Capture Scope Model

Postby FioranoCars » Tue Aug 15, 2017 1:38 pm

AuthorMike wrote:Under the General tab the large button at the top states "Reset 'Don't show this again' dialogs".
Click "OK"


Thanks Mike, the difference between a useful reply and a pointless one (Sorry STC but your reply did lack 2 things, One see below, the other was politeness)

Still does not resolve the issue posed ... as more to the point, when you achieve your startup via this screen, do you have the ability to see the channel setup for a waveform? NO ?
I thought not! (just tested to be sure, and you don't)

As, from memory (Pico team please confirm/clarify?), to be visible the channel options have to have a device selected, as they are generated specifically to the device specification you have connected or nominated. Each device has different abilities.

So the point of selecting "no Device" becomes mute as it would be useless for off-line editing in any event, or can be replicated by double clicking! We need to be able to edit offline WITHOUT losing the "capture" device details!

STC
If you want to reply, great, constructive and polite is best, make sure you've checked the final and full result otherwise it comes across as a bit like a :? :oops: :roll:

While your technical abilities are great, methods interesting, your manner sometimes leaves me :twisted: :twisted:

We know each other well enough for you to hopefully take this on board, as others might be intimidated by your direct and abrupt nature (it's just you, I know, I get that, you mean well), please play nice, by sounding nice!

As ever, your friend, yes really.
Richard
User avatar
FioranoCars
TwoWaves
TwoWaves
 
Posts: 377
Joined: Thu Dec 13, 2012 1:26 pm
Location: London, UK

Re: Feature Request - Capture Scope Model

Postby Martyn » Tue Aug 15, 2017 2:21 pm

What specific settings are you looking to edit ?

You can select the channel settings button and add filtering or resolution enhancement, but changing the voltage range or coupling would make no sense, there is no device to apply these to and the data has already been collected, which is why they are blank.

View->Properties is the best way to see how the scope was setup when the data was collected.
Martyn
Technical Support Manager
Martyn
Pico Staff Member
Pico Staff Member
 
Posts: 226
Joined: Thu Aug 11, 2011 9:43 am
Location: Cambridgeshire

Next

Return to PicoScope 6 Automotive software

Who is online

Users browsing this forum: No registered users and 0 guests