Volvo V50

Ask for and share advice on using the PicoScope kit to fix vehicles here.
RS-4
OneWave
OneWave
Posts: 20
Joined: Sun Jun 20, 2010 10:10 am

Volvo V50

Post by RS-4 » Sun Feb 05, 2017 1:36 pm

Hallo to all,

I need your help ... Problem is 2.0 Volvo V50 2009 (D4204T) engine will not start, which has an error P0087 - pressure too low. Signal from rail sensor has a lot of noise ... pump control (pwm) is ok... CR pump is new. The amount of fuel to the pump is ok. I measured fuel amount of the return pipes on injectors that's ok. I also need your opinion of the signal from the injector ...



Thanks
Attachments
pressure sensor + regulator on CR pump.psdata
(2.93 MiB) Downloaded 83 times
pressure sensor + injector cil.4.psdata
Pressure sensor to the voltage ok, enough? I think there is a lot of noise?
(3.8 MiB) Downloaded 107 times

dieseljohnny
OneWave
OneWave
Posts: 26
Joined: Mon Oct 12, 2015 9:08 pm

Re: Volvo V50

Post by dieseljohnny » Sun Feb 05, 2017 7:20 pm

Hi

Can you do a relative compression and injector current trace?
Also I think cranking speed is a bit slow if Im working it out right at 150Rpm approximately from the injector current trace.

Im just wondering why its throwing/or thrown a pressure too low fault but it appears to be actuating the injectors, well one of them anyway.

Perhaps its happening at the wrong time or other problem?

User avatar
STC
Banned
Posts: 790
Joined: Sun Sep 13, 2015 2:10 am

Re: Volvo V50

Post by STC » Sun Feb 05, 2017 7:38 pm

but it appears to be actuating the injectors,
It's not firing the injectors, measure the duration time, it is, at best, checking that they are there - Open / Short Circuit test ? Also explains the lack of Pilot Injection ?
150Rpm approximately from the injector current trace.
It goes around twice and fires once, I see Cranking speed as circa 282 Rpm.

Looking at FRP, the Fault Code is bang on - Pressure is low.

dieseljohnny
OneWave
OneWave
Posts: 26
Joined: Mon Oct 12, 2015 9:08 pm

Re: Volvo V50

Post by dieseljohnny » Sun Feb 05, 2017 8:17 pm

Makes perfect sense.

Sorry I posted without fully thinking through what I was looking at :oops:

With some filtering I can also see the effects of cranking on the rail pressure voltage.

User avatar
STC
Banned
Posts: 790
Joined: Sun Sep 13, 2015 2:10 am

Re: Volvo V50

Post by STC » Mon Feb 06, 2017 10:26 am

Johnny
Sorry I posted without fully thinking through what I was looking at :oops:
I think we can all be a little hit & miss on a Sunday Evening :D :D :D



RS

From memory that is Dual Point Control. SCV on the pump and a Pressure Regulator on the rail. Is that right ?
The amount of fuel to the pump is ok.
What Pressure and flow rate do you have ?

Do you have something to measure HP Pump Output - Delphi Sealed Rail Kit, Bosch Set 3 ..... ?

You could unplug the SCV and power the RPR to 90% with a PWM emulator, that should force it to produce maximum pressure. IF you do get the pressure up - Be sure to relieve it before cranking it again, or it will cause a lot of damage

I wouldn't worry too much about the noise on FRP right now, things are noisy at cranking.

steevegt
TwoWaves
TwoWaves
Posts: 70
Joined: Tue May 12, 2015 10:05 pm

Re: Volvo V50

Post by steevegt » Mon Feb 06, 2017 11:41 am

Hi,

STC, it looks like to me that it is firing the injectors. Piezoelectric ones, right?
In the beginning of the capturing, it looks like you do have a pilot injection with a 1.5 ms main injection opening time:
pilot and main injection.png
Pilot and Main injection event
Am I seeing this wrong?

At the end of the capture, the injector opening time is almost 5 ms. I believe this is too much, as far as I can tell!? But I guess it makes sense, because the opening time, for the same amount of fuel, has to be indirectly proportional to the pressure in the rail, right?
only main injection.png
Main injection event only
To clear the noise in the FRP sensor you could use the 1khz filter, like I did...
With that you can see on your first capture that the pressure looks like it is low, and very unstable also:
pressure.png
Low and unstable pressure

User avatar
STC
Banned
Posts: 790
Joined: Sun Sep 13, 2015 2:10 am

Re: Volvo V50

Post by STC » Mon Feb 06, 2017 4:29 pm

STC, it looks like to me that it is firing the injectors. Piezoelectric ones, right?
You have got me thinking twice now !!

First and foremost, with that DTC and Low Pressure they should not be firing. I would not be expecting them to.

I'm not so sure that the current draw to Open and Close the Stack is minimal - Possibly not enough to fire fuel.

RS-4
OneWave
OneWave
Posts: 20
Joined: Sun Jun 20, 2010 10:10 am

Re: Volvo V50

Post by RS-4 » Mon Feb 06, 2017 4:45 pm

Hallo,



Thank you very much for your answers. I know that the picture is clearer when filter's turn on but I think there is some problem and because of him are so many noises, perhaps I'm wrong.
I still fighting with the car ... Today I made a couple of shots ...crankshaft and camshaft signals are so bad the voltage drop is too large and the signals look bad. I checked the power and ground of ECU and that is ok. Maybe the problem is in the engine computer ... tomorrow I'll open it up to see what it looks like inside.

P.S. I also wonder why there is firing to the injectors when the rail pressure signal is bad...

I can to hook shots ... I do not know why

steevegt
TwoWaves
TwoWaves
Posts: 70
Joined: Tue May 12, 2015 10:05 pm

Re: Volvo V50

Post by steevegt » Mon Feb 06, 2017 5:52 pm

STC wrote: ...
I'm not so sure that the current draw to Open and Close the Stack is minimal - Possibly not enough to fire fuel.
The waveform structure of a piezoelectric injector is there, including (sometimes) the pilot injection event.
The current and the time width of the command, does look "short", I agree... I guess we need a good waveform of this system to compare and be 100%.
It could just be the computer way of detecting shorts, opens, etc. on the circuit, like you said.
Curious it does that with a pilot injection event also...
RS-4 wrote: ...
Thank you very much for your answers. I know that the picture is clearer when filter's turn on but I think there is some problem and because of him are so many noises, perhaps I'm wrong.
...
If you want, try to use the sensor ground, as the scope ground. It should clear the signal...
You are using the battery ground right?
RS-4 wrote: ...
Today I made a couple of shots ...crankshaft and camshaft signals are so bad the voltage drop is too large and the signals look bad. I checked the power and ground of ECU and that is ok. Maybe the problem is in the engine computer ... tomorrow I'll open it up to see what it looks like inside.
...
I don't understand very well what you are saying about volt drop, but I don't want to explore that also... :wink:
Post the files if you want. It's easier for someone to help that way.

How did you validate the power and ground of the ECU? Also validate the reference and ground of FRP sensor... That will be my next move, just to be sure. After that I would chase a bad pressure problem...

The injection timing events on the first files you send, they should rule, at least, the crank signal. The timing of them are very plausible...
RS-4 wrote: ...
P.S. I also wonder why there is firing to the injectors when the rail pressure signal is bad...
...
As far as I'm concerned, the injectors being fired is not a fact. At most a possibility...

User avatar
STC
Banned
Posts: 790
Joined: Sun Sep 13, 2015 2:10 am

Re: Volvo V50

Post by STC » Mon Feb 06, 2017 7:45 pm

Here is a known good from that Engine, I don't have one at cranking, only at Idle speed
D40 delete.jpg
And that turns my theory on its head :? I think I got too tied up with "They Shouldn't be Firing" and "if they are firing it should start" Hopefully not a completely insane thought process ???

We could sniff the Upstream DPF sensor pipe for Hydrocarbons ? Or fit a variable potentiometer in place of the FRP and wind it up from 0.5v up to 1.5v whilst scoping FRP and Injectors and look for change as it sees pressure and crosses the threshold.

RS
I still fighting with the car ... Today I made a couple of shots ...crankshaft and camshaft signals are so bad the voltage drop is too large and the signals look bad.
The car is shouting out at you in the way of a DTC that FRP is low, a fatal fault that will quite likely paralyse it. I am confused as to why you are not chasing that first.

Post Reply