corsa van 1.3cdti cranking no start

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

corsa van 1.3cdti cranking no start

Postby picocj » Sun Dec 18, 2016 12:56 pm

Hi I am currently helping a friend with a no start on a 2007 corsa van 1.3cdti with 100000 miles on the clock. Vehicle will crank and sounds like it is trying to start, occasionally it will start with a very bad misfire and excessive white smoke out the exhaust and will not take any throttle. Before looking at the vehicle it has had the fuel filter and turbo replaced also i have been told the egr has been removed and checked. This engine is not an engine i am familiar with but my first check was for dtcs with a souls no codes were present. Tested all the glow plugs with a current clamp which all tested good. unplugged injectors and listened to compression which also sounds good. Removed pipe from filter showing activation an flow of lift pump is goo. Viewing on data logger cranking fuel pressure is 300bar which matches desired pid and 1.3v measured at the frp. checked power side to injectors 12v and ground side seems to be switching al though just tested with a multimeter. I have access to a pico scope with current clamp can any one give me any suggestion as to common faults on this engine and explain expected current waveforms o these injectors. I am suspecting injectors being at fault. Any suggestions and advice would be appreciated.

Regards
picocj
Newbie
 
Posts: 2
Joined: Tue Oct 18, 2016 7:40 pm

Re: corsa van 1.3cdti cranking no start

Postby Dcunning35 » Sun Dec 18, 2016 9:08 pm

Does the rpm drop to zero whilst cranking in your live data? I got bit an the arse by a ford ka with this engine it bains me to this day I did everything checked it to death ,The only way to get it to run when it faulted was to ground the ckp although the waveform had excellent peak to peak voltage . I ended up placing a relay in ckp circuit to ground on crank it worked but not my finest hour .
Dcunning35
TwoWaves
TwoWaves
 
Posts: 191
Joined: Thu Jan 28, 2016 2:33 pm

Re: corsa van 1.3cdti cranking no start

Postby liviu2004 » Sun Dec 18, 2016 9:37 pm

egr stuck open? check again.
liviu2004
TwoWaves
TwoWaves
 
Posts: 52
Joined: Sat Mar 19, 2016 10:23 am
Location: Netherlands

Re: corsa van 1.3cdti cranking no start

Postby STC » Thu Dec 22, 2016 4:11 pm

engine and explain expected current waveforms o these injectors. I am suspecting injectors being at fault.


Use the current clamp to get waveforms of the injectors (all 4) and post them here. Get a good 5 seconds across the screen.

While you have it in your hand, do a relative compression test with the amp clamp.

checked power side to injectors 12v and ground side seems to be switching al though just tested with a Multimeter.


Unless you Load the circuit your Multimeter cannot be used to test the Power Side to the injectors, the circuit will be switching too fast for the meter to catch and display it with any accuracy, if at all.

This engine is not an engine i am familiar with


It is a four stroke Common Rail Diesel, treat it as you would any other. RPM, CKP, CMP, FRP, Compression, Air, Injectors Firing, Immobiliser .... .... ....
User avatar
STC
Banned
 
Posts: 790
Joined: Sun Sep 13, 2015 4:10 am

Re: corsa van 1.3cdti cranking no start

Postby Gorsracer » Fri Mar 03, 2017 2:45 pm

Did you find out what was wrong in the end? My cdti has developed the exact same symtoms.
Gorsracer
Newbie
 
Posts: 1
Joined: Fri Mar 03, 2017 2:36 pm

Re: corsa van 1.3cdti cranking no start

Postby blackbird007 » Sat Jul 01, 2017 1:40 am

Bit late now I guess but had this same fault on same vehicle. They had been running it every day with shot alternator. Charge over night and not turn off all day.
Persistent charge/flat battery removed all Ecu Id codes and programming.
Towed to dealers for recode. Sorted..
blackbird007
Newbie
 
Posts: 2
Joined: Wed Jun 24, 2015 7:44 pm


Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 0 guests