Passat ABS sensor

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

Passat ABS sensor

Postby victor2k » Tue Aug 09, 2016 3:59 pm

Hello,
I have some strange issue on Passat 2011/2.0d/CFFB engine type.
On ABS I have a fault on the rear right sensor(incorect signal).OE sensor is made by ATE(hall or magnetoresistive).
The supply of sensor was checked(measured 11v),wires was checked(0,5-0,7 ohm).
Replacing the sensor(with a Delphi made sensor) I have the same fault.Disconecting the sensor I have open circuit/short to gnd.ABS ecu detect something what I can't...
Erasing the fault memory(at second 0) I have the supply for sensor only for 1,5 seconds...how to check the new and the old sensor?The repair manual don't let me to check the resistence-sensor can be damaged.
Attached the supply singal for the rear right sensor when the fault memory is erased with KTS.
Thank you.
Attachments
Volkswagen_Passat_Diesel_20160809-0001.psdata
(282.35 KiB) Downloaded 38 times
victor2k
Advanced User
Advanced User
 
Posts: 75
Joined: Thu Jan 28, 2016 7:17 am

Re: Passat ABS sensor

Postby STC » Tue Aug 09, 2016 4:54 pm

I cant open your data file because I need to update my pico software. Will do that later.

I'm guessing that this has Intelligent - Active Sensors (Im guessing 2 pin) so you cant really test them for resistance. All you would measure (or destroy) would be the tiny pcb and components in there.

The ABS will shut down the power supply to that sensor if it detects a fault in 1.5 seconds.

Plug your old (suspected) bad sensor and / or your new one into the connector on the opposite known good side. Use breakout leads if need be. Clear codes and see what comes back. That will confirm or condemn the sensors. all that you have left then is wiring or module.
User avatar
STC
Zen Master
Zen Master
 
Posts: 354
Joined: Sun Sep 13, 2015 2:10 am

Re: Passat ABS sensor

Postby victor2k » Tue Aug 09, 2016 5:25 pm

Hello,
I swapped the left rear sensor and rear right sensor and fault moved to rear left wheel.I will use ATE sensor,not Delphi to fix the car.
What fault can detect ABS Ecu?An excessive supply curent?With both(good and bad) sensors the supply voltage is 11,5v.
Also I can see some"wear "of magnetic ring of bearing at rear right wheel(using a endoscope) but not on sensor head.
This "wear" can give me a faulty signal?
Thank you.
Last edited by victor2k on Tue Aug 09, 2016 5:35 pm, edited 1 time in total.
victor2k
Advanced User
Advanced User
 
Posts: 75
Joined: Thu Jan 28, 2016 7:17 am

Re: Passat ABS sensor

Postby roadserpent » Tue Aug 09, 2016 5:33 pm

I get the same message when I try to open the file. So I tried to update Pico software and it says no updates available, so whats up ?
roadserpent
User
User
 
Posts: 21
Joined: Fri Sep 19, 2014 4:33 pm

Re: Passat ABS sensor

Postby victor2k » Tue Aug 09, 2016 5:38 pm

roadserpent wrote:I get the same message when I try to open the file. So I tried to update Pico software and it says no updates available, so whats up ?

Hello,
I use 6.12.1 Beta version on my laptop with 4425 and I think Pico will not tell you if a beta is available for download.
victor2k
Advanced User
Advanced User
 
Posts: 75
Joined: Thu Jan 28, 2016 7:17 am

Re: Passat ABS sensor

Postby roadserpent » Tue Aug 09, 2016 6:37 pm

Thank you V2k
roadserpent
User
User
 
Posts: 21
Joined: Fri Sep 19, 2014 4:33 pm

Re: Passat ABS sensor

Postby STC » Tue Aug 09, 2016 7:12 pm

I swapped the left rear sensor and rear right sensor and fault moved to rear left wheel. I will use ATE sensor, not Delphi to fix the car.


If you moved the sensor and the fault moved with it then you have a faulty sensor. Where are you buying the Sensors from ?
I would forget ATE & Delphi (A lot of Clones out there) but use a genuine dealer part.
User avatar
STC
Zen Master
Zen Master
 
Posts: 354
Joined: Sun Sep 13, 2015 2:10 am

Re: Passat ABS sensor

Postby victor2k » Wed Aug 10, 2016 4:49 am

Hello,
The new Delphi part was buyed from a local shop as equivalent for OE part made by ATE...
Today I made new measurements...the signal is very small(80 mV amplitude).I used *50 magnifier to see the diference
I will attach the signal registered from a good sensor
Attachments
VW_PASSAT_20140711-0006.psdata
(2.09 MiB) Downloaded 22 times
victor2k
Advanced User
Advanced User
 
Posts: 75
Joined: Thu Jan 28, 2016 7:17 am

Re: Passat ABS sensor

Postby victor2k » Wed Aug 10, 2016 6:38 pm

And the signal registered from a bad sensor(from frame 27 to 30).
Attachments
VW_PASSAT_20140711-0007.psdata
(7.76 MiB) Downloaded 30 times
victor2k
Advanced User
Advanced User
 
Posts: 75
Joined: Thu Jan 28, 2016 7:17 am

Re: Passat ABS sensor

Postby STC » Wed Aug 10, 2016 10:09 pm

And that tiny signal Rides on the positive wire ? Just pulls it down a tiny bit ??

Different Duty for Standstill, forwards, backwards & Increased Air Gap. Then the frequency of wheel speed piggy banked on it.

It takes a good scope & it's jockey to analyse that component in detail.
User avatar
STC
Zen Master
Zen Master
 
Posts: 354
Joined: Sun Sep 13, 2015 2:10 am

Next

Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 1 guest