Audi A4 2.0 TDI Rough idle

Ask for and share advice on using the PicoScope kit to fix vehicles here.

Re: Audi A4 2.0 TDI Rough idle

Postby grunf1976 » Sun Jan 14, 2018 11:17 am

Hi,
Sorry for late reply lot of work.... :D . The problem I had was with 2012 VW Passat. Car came with EGR fault code, but they already changed not one but two and only then decided to ask for help.
When the car was cold idle was unstable and when you start driving it feels like its misfiring and there was a slight judder. It was more noticeable because of DSG transmission. Problem started to disappear as the temperature rises and when it reached over 70 degrees C it ran normal. Did all the tests, EGR, DRV, IMV, MAF.... and it all lead me to believe that it has something to do with amount of fuel. Took of injectors and had them tested. Only one passed the test on the bench. Had them repaired and recoded car ran excellent. No symptoms or fault code.
Two days ago has Skoda Superb same thing....

Hope this helps..
Mickey
grunf1976
OneWave
OneWave
 
Posts: 43
Joined: Tue Dec 15, 2015 5:05 pm
Location: Belgrade, Serbia

Re: Audi A4 2.0 TDI Rough idle

Postby nelnun » Sun Feb 04, 2018 12:41 pm

grunf1976 wrote:Hi,
Sorry for late reply lot of work.... :D . The problem I had was with 2012 VW Passat. Car came with EGR fault code, but they already changed not one but two and only then decided to ask for help.
When the car was cold idle was unstable and when you start driving it feels like its misfiring and there was a slight judder. It was more noticeable because of DSG transmission. Problem started to disappear as the temperature rises and when it reached over 70 degrees C it ran normal. Did all the tests, EGR, DRV, IMV, MAF.... and it all lead me to believe that it has something to do with amount of fuel. Took of injectors and had them tested. Only one passed the test on the bench. Had them repaired and recoded car ran excellent. No symptoms or fault code.
Two days ago has Skoda Superb same thing....

Hope this helps..
Mickey

Hi, thanks for your reply!
Well, it seems that yours symptoms were a little bit different! I've never had any fault code! I've replaced all the 4 injectors, it is better, but the problem when restarting the engine after 3/4m from cold, it is still there :roll:
nelnun
OneWave
OneWave
 
Posts: 15
Joined: Thu Nov 02, 2017 12:58 am

Re: Audi A4 2.0 TDI Rough idle

Postby nelnun » Sun Feb 04, 2018 1:55 pm

Some updates and tests:

When cold, it idles right. Turn engine off with a coolant temp around 36ºC. Turn back on and still idle fine. When coolant temp reaches 39,6ºC (can take 1 or 2 minutes), after 6 to 15 seconds, rough idle appears (if I turn engine on with coolant temp around 40-45ºC, rough idle starts immediately). Looking to VCDS, just after the rough idle, injection quantity increases and fluctuates between 6-9mg and injection deviation starts to increase too (I've seen a maximum of +2.2 mg/str), sometimes on injector 1, next time injector 3, injector 4 sometimes also... I've never seen bad positive values on injector 2. I've swapped before, injectors 2<->3 and 1<->4. Positive values moved from 2 to 3, 1 and 4 have both positive values, it depends! Usually, only 1 injector at a time has a deviation >2mg/str. But, in ome tests that I've made, when it has a rough idle, all deviation along the 4 injectors are between +0.5 and -0.5mg.

Injection_3.jpg
Inject_3


If I disconnect the intake manifold flap motor plug during the rough idle, intake flaps are in the "opened" state and idle is back to normal. Injection quantity and injectors deviation decreases and estabilize:

Injection_4.jpg
Inject_4


If I disconnect the flap motor and then move the motor shaft to the close position with my finger, when it is almost full closed, idle is back to normal and so are injection quantity and injection deviation:

Injection_5.jpg
Inject_5


I'm starting to believe that dealer is right and this is an injectors issues...

Another test:

Injection_6.jpg
Inject_6


What I've done so far:
- Injectors ultrasonic clear (only the nozzles on the machine water)
- Intake manifold flaps ultrasonic clear (flaps seem to open and close fine)
- Lambda sonde replaced

Sorry for the loooong post :oops:
nelnun
OneWave
OneWave
 
Posts: 15
Joined: Thu Nov 02, 2017 12:58 am

Re: Audi A4 2.0 TDI Rough idle

Postby nelnun » Sat Feb 10, 2018 11:57 pm

What do you think about the difference between Rail pressure Specification and Rail Pressure Actual?
Could this be related to a faulty DRV?

Rail Pressure_2.jpg
Rail press 2

Injectors already replaced with no joy... :roll:
Last edited by nelnun on Mon Feb 12, 2018 3:32 pm, edited 2 times in total.
nelnun
OneWave
OneWave
 
Posts: 15
Joined: Thu Nov 02, 2017 12:58 am

Re: Audi A4 2.0 TDI Rough idle

Postby KimAndersen » Sun Feb 11, 2018 11:58 am

Hi Nelnun

The injectors you replaced are they new or used and have they been recoded with the correct IMA number from the injectors !!!.

Regards
Kim
KimAndersen
TwoWaves
TwoWaves
 
Posts: 197
Joined: Fri Nov 30, 2012 4:53 pm
Location: Denmark

Re: Audi A4 2.0 TDI Rough idle

Postby nelnun » Mon Feb 12, 2018 12:45 am

KimAndersen wrote:Hi Nelnun

The injectors you replaced are they new or used and have they been recoded with the correct IMA number from the injectors !!!.

Regards
Kim

Hi Kim,
They are all 4 refurbished by bosch. IMAs were recoded, but it doesn't matter as when the engine has a rough idle, it is behaving the same ways as before!
Every time I start the engine with a coolant temperature around 40ºC, it'll always idle bad, i.e. If I shut down the engine with a coolant temp of 80/90ºC and let it cool down for 1h/2h and start the engine, rough idle and the exhaust bad smell are back!

I've removed the DRV today and cleaned it, no joy! I've mande a "trim reset" (coding II = 10008 ), let see tomorrow, but I don't think it will work!
Could this be a sw issue? I didn't update it yet to the new "NOx" version!

Beware that the pressure diference between spec and actual only happens in the rough idle! From cold or warm, the difference is very small!
nelnun
OneWave
OneWave
 
Posts: 15
Joined: Thu Nov 02, 2017 12:58 am

Re: Audi A4 2.0 TDI Rough idle

Postby nelnun » Mon Feb 12, 2018 11:15 pm

About the rail pressures.

This is a normal cold start. Spec value is always stable, it is always the same, only actual pressure fluctuates a bit, but I think that's normal:

Cold Start
Rail Pressure_4.jpg


And this is what I think that is not normal, pressure spec fluctuating a lot. Why is the ECU continuously changing spec values? What could originate this?

Rough Idle
Rail Pressure_3.jpg

Edit: In this last graphic, I've used info from "High Fuel Pressure - (specified)" on vcds group 19-2 and the first one from group 20-1, and even with the same name, they are different! 20-1 is a stable value, 19-2 is not!
nelnun
OneWave
OneWave
 
Posts: 15
Joined: Thu Nov 02, 2017 12:58 am

Re: Audi A4 2.0 TDI Rough idle

Postby nelnun » Tue Feb 13, 2018 5:00 pm

This is how it idles!
Unfortunately, this time, I was unable to have a very rough idle to show you the engine failing and shaking, it is difficult to replicate when the temp outside is cold (13ºC o this case), but it is there and it is "visible" when I start moving the car, as it kangaroos till around 2000rpm.
Check the rattle injection noise when accelerating up the hill.

https://youtu.be/Z_H58acVpyw
nelnun
OneWave
OneWave
 
Posts: 15
Joined: Thu Nov 02, 2017 12:58 am

Re: Audi A4 2.0 TDI Rough idle

Postby nelnun » Wed Feb 21, 2018 1:43 am

Meanwhile, I've made a few more tests! I've connected a potentiometer to the coolant sensor plug to emulate an engine temperature of my choice! I've emulated 41ºC and 45ºC in a cold and warm engine!

With the engine cold and 40ºC of emulated temp, after around 5s of start and there is the rough idle again! With the engine warm, rough idle was not perceptible, but as soon as I start moving, it kangaroos with a very rattle injection noise, as usually! Idle and behaviour is always back to normal after 1 or 2 accelerations over 2000RPM!

What I was able to conclude is that when I start the engine with a coolant temp of 40ºC to 50ºC, it'll always have a rough idle/rattle injection/kangaroos, no matter what the real engine temp is! What I've found strange is that some Specification values (like Exhaust Gas - Recirculat, Injection Start BTDC) have a value before shut down and after restart, they have lower values, and that doesn't happen when the coolant temp is outside the range 40-50ºC.... But the differences are very small and should not explain the rough idle, but probably there are some other values (injection?, etc) that change as well......

Image
nelnun
OneWave
OneWave
 
Posts: 15
Joined: Thu Nov 02, 2017 12:58 am

Re: Audi A4 2.0 TDI Rough idle

Postby Shooter » Fri Feb 23, 2018 11:36 pm

Can we see a Crank Sensor waveform, with at least 4 or 5 revolutions across one screen, when it is running bad ?
Shooter
Newbie
 
Posts: 4
Joined: Wed Oct 25, 2017 11:26 am

PreviousNext

Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests