Kia Sorento 2.5 Crdi 2006 automatic transmission

If you are not a PicoScope user and want advice with a diagnostic problem then post here. Forum members may be able to help.

Kia Sorento 2.5 Crdi 2006 automatic transmission

Postby atomeromu » Wed Jul 08, 2015 8:23 pm

Hi Folks,

I`m having this jeep in my garage. It has intermittent non running problems. I mean the engine always starts and runs but just for 1-2 sec than cuts off. There are no fault codes in the ECU. Every 10-15 times try the engine runs fine with no problem. I have checked every signal with my Pico and all signals are looked good. The engine stops because the injectors are no longer getting signal from ECU. In that case it`s not an immo fault. This engine is a chain driven engine and to check the timing it`s a pain in the hole. Sadly I`m not really a Pico expert so when I checked the crank and cam signals relations and I`m not sure they are good or bad the timing it`s ok or not?!
Also the automatic gearbox doesn`t change gears in Drive mode and I can`t communicate with it. I don`t think this has anything to do with the "non running" issue.

Any help?

Posts: 1
Joined: Wed Jul 08, 2015 7:59 pm

Re: Kia Sorento 2.5 Crdi 2006 automatic transmission

Postby PicoPhil » Fri Sep 11, 2015 10:42 am

Welcome to the forum group.
Sorry that your request has not received a reply.Do you still have the vehicle ?
At Pico we cannot help but promote the waveform library for all users to upload and download their captured waveforms. Even if you are unsure about the waveform this may help someone. If we have a non start vehicle, camshaft and crankshaft
data is so important with perhaps an injector. Please mark the waveform unknown, if not sure or put information into the notes section.
Pico Staff Member
Pico Staff Member
Posts: 69
Joined: Thu Dec 23, 2010 11:38 am

Return to Help me fix my car

Who is online

Users browsing this forum: No registered users and 0 guests