Waveform Library Issue

Ask any questions about using PicoScope Automotive software here.

Waveform Library Issue

Postby abndanger » Sat Jun 27, 2015 9:43 am

I was trying to upload several WPS captures onto the library. The issue is, the size limit of the file to be upload. Even though my file is only 15mb in size. It states on the library it has exceeded the limit.

I know when taking a capture I run the scope at 500ms/div and 4ms sample rate(sometime more). Normally if this is done it will create a file larger than 20mb to be uploaded.

If you guys can. It would be nice to increase the file size to be uploaded. I know on the AutoNerdz side Tom has increase the upload file size. If they are to big we usually upload to the drop site. I would think the waveform library would act like a FTP site and be able to upload any large size file.

I must have over a hundred good and bad captures to upload. But, if the library can't handle it. I will more than likely drop them on the AutoNerdz site.

Thanks,

Bob
abndanger
Newbie
 
Posts: 4
Joined: Thu Jun 05, 2014 1:01 am

Re: Waveform Library Issue

Postby Alan » Mon Jun 29, 2015 9:27 am

Hi Bob,

Our concern at the start was not to end up with too many huge files where the size was not justified (100 million samples of battery voltage....)

As the limit is preventing users from uploading useful files we will increase the limit as you and others have suggested. If we can do this without a software update it should be in the next couple of days. If it needs a new release of PicoScope to do this it will be several weeks.

Regards
Alan
Alan
Pico Staff Member
Pico Staff Member
 
Posts: 239
Joined: Thu May 25, 2006 8:02 am

Re: Waveform Library Issue

Postby abndanger » Tue Jun 30, 2015 9:31 am

Hello Alan,

Thanks for the fast reply :D

I know Pico released the new update of 6.10.18.149. Waiting to see if they fixed any bugs or create more.

I appreciate you guys addressing our concerns. I do know some people can get carried away with large file :D

Please keep us posted as to the out come and when we may start uploading larger files.

Bob
abndanger
Newbie
 
Posts: 4
Joined: Thu Jun 05, 2014 1:01 am

Re: Waveform Library Issue

Postby Alan » Tue Jun 30, 2015 10:46 am

Hi Bob,

We have done some work on this already. Its one of those things that seemed easy but was a bit more complicated than it looked. PicoScope has a limit, the server we use has both a size and time to upload limit.

Where we are now is that files of 20Meg (and perhaps a bit more) should now upload OK so please could you try your 15Meg file again.

To increase it further will require changes in PicoScope so that will have to wait for a future release.

Regards
Alan
Alan
Pico Staff Member
Pico Staff Member
 
Posts: 239
Joined: Thu May 25, 2006 8:02 am

Re: Waveform Library Issue

Postby tode » Tue Jun 30, 2015 8:34 pm

I exploit the discussion, to ask, if possible in the future, more names to describe the waveforms, such as:
new systems multiair;
Valvetronic systems, (actuator and position sensor);
Devices for handling urea;
actuator and position sensor, but above all actuating devices, such as plates command windows or light control with PWM;
Signal indicator tank;
......
Interesting would be an empty box, where the write device, which concerns the waveform, in this case, the waveform may be checked by a moderator.
I believe a lot in this library and I think that is well made and well organized with a good search engine.
Thanks and good job.
tode
User
User
 
Posts: 42
Joined: Fri Jun 20, 2014 6:59 pm

Re: Waveform Library Issue

Postby Alan » Thu Jul 02, 2015 9:48 am

Hi,

Thanks for the suggestion - there are dozens of names for the waveforms (channel labels) already in the software. No such list however can really be complete so we both included the option to add your own and always planned to add more to the list based on user suggestions.

We have a list of more names we want to add, I will see if we can get that list posted on the forum and then ask for suggestions on other "missing" waveform names. If we all use the same names to describe what we are measuring it makes it easier to search for waveforms.

Regards
Alan
Alan
Pico Staff Member
Pico Staff Member
 
Posts: 239
Joined: Thu May 25, 2006 8:02 am

Re: Waveform Library Issue

Postby abndanger » Sun Jul 05, 2015 4:37 pm

Allan,

I logged in today and uploaded a file. I did the save & share. It looked like it went through on my end without any file size issues, but when I go to view my account for the waveform it is not there. Heck I can't even search for it. Shows nothing. Not sure if this is something I am doings wrong or best I just keep it to the AutoNerdz site for simplicity. Better resources on their site less hassles.
abndanger
Newbie
 
Posts: 4
Joined: Thu Jun 05, 2014 1:01 am

Re: Waveform Library Issue

Postby Autonerdz » Mon Jul 06, 2015 3:37 pm

Hi Bob,

When Alan was visiting us last month one of the things we discussed was this waveform library file size issue.

I mentioned your concerns and now that we are getting something done, let's follow up and see it through.

Feel free to give us a call when you have time to screen share and maybe we can assist.
User avatar
Autonerdz
Zen Master
Zen Master
 
Posts: 272
Joined: Wed Nov 20, 2002 4:19 pm
Location: Washington State USA

Re: Waveform Library Issue

Postby abndanger » Tue Jul 07, 2015 1:24 am

Hey Tom,

Thanks for the input and follow up. Glad to see Allan and his team are being proactive. :D

I will call you guys this week once I get a handle on a few Case Study's. We can see if I am doing something wrong or if it is a software issue or both :)

Thanks again,

Bob
abndanger
Newbie
 
Posts: 4
Joined: Thu Jun 05, 2014 1:01 am

Re: Waveform Library Issue

Postby botlik30 » Wed Jul 08, 2015 10:41 am

I can not enter the library waweform login
botlik30
Newbie
 
Posts: 2
Joined: Wed Jul 08, 2015 10:32 am

Next

Return to PicoScope 6 Automotive software

Who is online

Users browsing this forum: No registered users and 1 guest