Return of the BUG.

Ask any questions about using PicoScope Automotive software here.

Return of the BUG.

Postby Fat Freddy » Sat Apr 11, 2015 11:43 am

This one drives me nuts.

Did it go? Has it reappeared? . It's bugging.

Version
PicoScope® 6 - PC Oscilloscope software version: 6.10.16.2
Copyright © 1995-2015, Pico Technology Ltd

There is no device connected.

Psdata files - "For Steve" and "For Steve II" found here topic10481.html
Zoom is busted. Either the waveform has disappeared or the line is fat as.

This is a particularly annoying bug as it makes the buffer size irrelevant. Perhaps it's a fault at my end. Either way, I'm sure I'm not the only one.

Can this be fixed once and for all. I'm sure this is a reoccurring annoying bug.

Cheers
FF
User avatar
Fat Freddy
Zen Master
Zen Master
 
Posts: 267
Joined: Fri May 04, 2012 4:52 am

Re: Return of the BUG.

Postby Autonerdz » Sat Apr 11, 2015 3:11 pm

It's not you mate.

It appears that the files were saved with the broken 'Only save zoomed region' feature.

While this feature reduces file size and is less broken than it has been in the past, it creates confusing files like this which drive you nuts if you don't know. The zoomed out view shows all the capture but it's not really there. Only the data in the zoomed region has been saved. Attempting to examine areas outside of this region either shows nothing, or a blocky fat color crayon representation.

Tom Roberts
Autonerdz.com
The only PicoScope automotive specialists
User avatar
Autonerdz
Zen Master
Zen Master
 
Posts: 265
Joined: Wed Nov 20, 2002 4:19 pm
Location: Washington State USA

Re: Return of the BUG.

Postby Fat Freddy » Sat Apr 11, 2015 11:24 pm

Thanks for that.
That makes sense. I forgotten I had posted a file up that was saved with the 'Only save zoomed region' feature.

When I saw it gave nasty flash backs to a previous bug when zooming in (shivers up spine). It probably explains why when using reference waveforms it wouldn't reduce file size down from the original 12.5MB
Overall though I think it's a cool feature.

Cheers
FF
User avatar
Fat Freddy
Zen Master
Zen Master
 
Posts: 267
Joined: Fri May 04, 2012 4:52 am

Re: Return of the BUG.

Postby Steve Smith » Mon Apr 13, 2015 9:20 am

Thank you both for the feedback and the explanation Tom.

I will file a bug for this issue and include these waveforms as an example.

Thanks again, take care.......Steve
Steve Smith
Pico Staff Member
Pico Staff Member
 
Posts: 426
Joined: Sun Aug 25, 2013 7:22 am


Return to PicoScope 6 Automotive software

Who is online

Users browsing this forum: No registered users and 1 guest