Ford Focus 1.6 Ti-VCT P0341

Ask for and share advice on using the PicoScope kit to fix vehicles here.

Ford Focus 1.6 Ti-VCT P0341

Postby gregs303 » Thu Feb 12, 2015 9:56 pm

Hi all,
I'm working on 2006 Focus,1.6 Ti-VCT HXDA EM light on P0341 Camshaft position sensor A range performance.
Also P0016 Cam to crank correlation A and P0017 Cam to crank correlation B
I have replaced timing belt and intake camshaft gear, timing was out and cam gear had a slack.

Previous garage replaced both camshaft sensors and crank sensor.

Can I have a opinion on the waveform attached, this is as it is now, P0341 comes back immediately after being cleared and engine idling.

https://drive.google.com/file/d/0B9tZ5k ... sp=sharing
Sorry, must use the link as I can't upload any files directly.
(Tried about 10 times with different browsers)

Looking on reference waveform from pico library (same engine) it looks spot on, maybe there is something I don't see.
And here pico waveform from library
https://drive.google.com/file/d/0B9tZ5k ... sp=sharing

Any suggestions will be greatly appreciated.

Cheers
Greg
gregs303
Newbie
 
Posts: 7
Joined: Wed Feb 04, 2015 8:12 pm

Re: Ford Focus 1.6 Ti-VCT P0341

Postby tode » Sat Feb 14, 2015 1:03 pm

looking at the files you have added to your car is out of phase by about 17 ° of crankshaft, the command of the VVT is similar varies little, the signals of the intake and exhaust cams are equal to the reference signal (library).
I took the two signals that you provided, I took as a reference signal crankshaft, put the ruler with degrees and with sliders measured the falling edges of the signal camshafts, comparing them I understand is how many degrees out of phase.

your signal.jpg
Your signal .


library signal.jpg
Library signal, the command of the VVT is similar it varies little.


if I remember correctly in this motor pinion shaft is without key and must use a retainer for the phase.
tode
User
User
 
Posts: 42
Joined: Fri Jun 20, 2014 6:59 pm

Re: Ford Focus 1.6 Ti-VCT P0341

Postby gregs303 » Sun Feb 15, 2015 5:15 pm

You are correct, I just roughly counted the crankshaft notches but yes it is 17 deg out using rulers.

Well this answers my question.

Thanks
gregs303
Newbie
 
Posts: 7
Joined: Wed Feb 04, 2015 8:12 pm


Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests