Golf MK5 2.0 PD Wipers at fault

Ask for and share advice on using the PicoScope kit to fix vehicles here.

Golf MK5 2.0 PD Wipers at fault

Postby SamP » Mon Jun 09, 2014 7:59 am

Hello all pico users. I am struggling because my lack of knowledge.
Wipers in my car suddenly stopped working. Stripped it down, check and lubed mechanical linkages and without wiper blades in place motor works but after putting blades back on motor tries to run but can't push wipers.
Motor have 3 wires, constant power, good groung and LIN wire.
I did check current on power wires and voltage on lin and can't work out what is wrong.
Please direct me if fellow friends.
motor wiper current , lin.psdata
(2.6 MiB) Downloaded 242 times
Posts: 4
Joined: Mon May 06, 2013 5:49 pm

Re: Golf MK5 2.0 PD Wipers at fault

Postby PicoPhil » Mon Sep 14, 2015 1:44 pm

Hi SamP
I would want to look at the wiring diagram of the system. For basic information, Diagnostic Assistance is very good on testing systems. You can purchase from our web part number DI095.
Did you capture any other signals with the scope ?
Pico Staff Member
Pico Staff Member
Posts: 69
Joined: Thu Dec 23, 2010 11:38 am

Re: Golf MK5 2.0 PD Wipers at fault

Postby clt » Sat Sep 19, 2015 8:24 am

if I remember right the wiper does not move If the bonnet is not closed. If there is rain sensor the Lin-bus signal will also be up there. Perhaps the fault could be in the rain sensor.
Posts: 5
Joined: Thu Nov 20, 2014 9:35 pm

Return to Diagnostic discussion

Who is online

Users browsing this forum: No registered users and 0 guests