Pico 6.8.11.20 corrupted my psdata files

Ask any questions about using PicoScope Automotive software here.

Pico 6.8.11.20 corrupted my psdata files

Postby PatL » Mon Apr 14, 2014 4:37 am

I just opened a psdata file I created about 1 month ago, modified some labels on the channels and pulled up some ruler bars, saved it and when I tried to reopen it, it would not open saying it was corrupted. It happened to 2 files so I am afraid to open any more. Anyone else have this problem or suggest a way to recover them?

I am using Windows XP. Been using Picoscope for years and never had a problem
PatL
User
User
 
Posts: 15
Joined: Wed Dec 26, 2012 4:09 pm

Re: Pico 6.8.11.20 corrupted my psdata files

Postby PatL » Mon Apr 14, 2014 4:58 am

I should have mentioned that this is Pico Automotive and I just updated it about 1 week ago to 6.8.11.20 from the version being used when I created the original files that are now corrupt
PatL
User
User
 
Posts: 15
Joined: Wed Dec 26, 2012 4:09 pm

Re: Pico 6.8.11.20 corrupted my psdata files

Postby Liteace » Mon Apr 14, 2014 7:46 am

Im having a bit of a problem with 6.8.11.20 last night, I also loaded a psd file, after 5 - 10 mins of working with rulers it just locked up and became unresponsive, trying to close the program would bring up the this program is not responding window, this happened 3 time with half hour and only with the last 2 updates, before that not a problem, Im also using Win XP
Liteace
Guru
Guru
 
Posts: 156
Joined: Fri Jan 27, 2012 12:25 pm

Re: Pico 6.8.11.20 corrupted my psdata files

Postby Steve Smith » Mon Apr 14, 2014 9:56 am

Hi PatL and thanks for posting your concern here. I am so sorry you are experiencing issues with previously saved files when using the new software. We all know the value of saved data and so we must resolve this ASAP.
Can you send the now corrupted file to support@picotech.com along with the trace-file.
The trace-file will provide essential information about your system and what happened during the attempt to open the corrupted file. Could you attempt to open this corrupted file, wait for the error message and then close the PicoScope program. This will create the trace-file relevant to the attempts to open the corrupted file.
To access this trace file please see the attached file on how to find the trace file.
Could you also send a file you have saved with old software but not amended with new software?

Hi Liteace, once again, sorry you to are experinece issues when working with files. This does sound like a different issue to PatL but never the less we need to get to grips with this ASAP. Could you also follow the details above and send the relevant trace file and the file you have experienced issues with to support@picotech.com

Once again, thank you both for taking the time out to post these concerns and we will endeavour to resolve them ASAP
Take care......Steve
Attachments
LOCATING THE TRACE FILE XP ONLY.docx
(160.27 KiB) Downloaded 172 times
Steve Smith
Pico Staff Member
Pico Staff Member
 
Posts: 442
Joined: Sun Aug 25, 2013 7:22 am

Re: Pico 6.8.11.20 corrupted my psdata files

Postby PatL » Sun Apr 20, 2014 3:31 pm

I sent the files last night to the email link. The trace file was in a lower level folder than described in the document but based on the time stamp I believe I sent the correct xml file.

I appreciate finding out what happened because I don;t want to lose any more of my historical files.

thanks
PatL
User
User
 
Posts: 15
Joined: Wed Dec 26, 2012 4:09 pm

Re: Pico 6.8.11.20 corrupted my psdata files

Postby PatL » Wed Apr 23, 2014 1:36 am

I sent the files in as requested and here is the email I got back. Seems like a disconnect.

"I am afraid we are unable to recover corrupt PicoScope6 files at all. You are thinking about PicoLog files which we can usually recover with a matching good file but that is not possible with PicoScope, sorry.

Please contact me again if you have any other questions.
Regards,
PeterF."
PatL
User
User
 
Posts: 15
Joined: Wed Dec 26, 2012 4:09 pm

Re: Pico 6.8.11.20 corrupted my psdata files

Postby Martyn » Wed Apr 23, 2014 9:02 am

Apologies, Steve will be contacting you via our ticketing system for some more information, the email you received was from a colleague on the Test and Measurement team who was unaware of the ongoing conversation.
Martyn
Technical Support Manager
Martyn
Pico Staff Member
Pico Staff Member
 
Posts: 177
Joined: Thu Aug 11, 2011 7:43 am
Location: Cambridgeshire

Re: Pico 6.8.11.20 corrupted my psdata files

Postby Steve Smith » Wed Apr 23, 2014 9:58 am

Hello Pat from Steve Smith and thank you for your feedback. First of all can I apologise for the misunderstanding regarding your corrupt files. Today is my first day back after the Easter holidays and my colleague was not aware of the incoming files and the issues surrounding the corruption of these files. This is my fault as I should have informed colleagues that your files may be coming through and for this I apologise. I have sent you some feedback via the support desk and have sent your files to the software team for evaluation. Rest assured we are on the case.

Take care.....Steve
Steve Smith
Pico Staff Member
Pico Staff Member
 
Posts: 442
Joined: Sun Aug 25, 2013 7:22 am

Re: Pico 6.8.11.20 corrupted my psdata files

Postby PatL » Thu Apr 24, 2014 4:27 am

Steve,

No worries. Seemd like maybe there was a disconnect.

I forwarded you the files you requested just now.

Pat
PatL
User
User
 
Posts: 15
Joined: Wed Dec 26, 2012 4:09 pm

Re: Pico 6.8.11.20 corrupted my psdata files

Postby Steve Smith » Thu Apr 24, 2014 3:55 pm

Hello Patrick and thank you for your patience on this one. It would appear there is a glitch within the software that can, under certain circumstances, fail to open psdata files after amendments. The issue is under investigation with the software team and I will feedback to you as soon as possible.
This fix will most likely be released within the next build either as a Beta or stable version depending on the time frames involved. I have to apologise again for this nuisance issue that appears to affect certain psdata files, but not all. The software however is working correctly for captures, saving and reviewing and only appears to glitch with a very fine band of older psdata files.
What we do know is older psdata files that are opened and amended with the new software (6.8.11.20) can be reopened as long as they are NOT overwritten. (In other words “save as” and NOT “save”).
E.g.
1. Open older psdata file with new software (6.8.11.20)
2. Amend the file as required
3. Click on “save as” NOT “save” as this will create a new file and not overwrite the old file
4. This will ensure you have the new amended file and the original.
I hope this helps until the new build arrives, and once again my sincere apologies for the mix up above and the glitch within the software.
Thank you also for posting the concern which has raised the alarm here at Pico and rest assured we will have a new build very soon
Take care....Steve
Steve Smith
Pico Staff Member
Pico Staff Member
 
Posts: 442
Joined: Sun Aug 25, 2013 7:22 am

Next

Return to PicoScope 6 Automotive software

Who is online

Users browsing this forum: terbo and 3 guests