PicoScope 4444 streaming example in LabVIEW

Ask any non-NVH related questions about using PicoDiagnostics software here.
Post Reply
dsedano
Newbie
Posts: 1
Joined: Fri Jan 12, 2018 2:17 pm

PicoScope 4444 streaming example in LabVIEW

Post by dsedano » Fri Jan 12, 2018 2:44 pm

Good morning,

I have recently acquired a PicoScope 4444 and I would like to obtain some data readings by streaming in LabVIEW. For that, I am trying to use the example given by SDK, but I have some issues with it.

First of all, I would like to point out that I found a problem in the LabVIEW (32-bit) design of the program PicoScope4000aExampleStreaming. In the OpenUnit.vi module, the elements in the Call Library Function for the "OpenWithResolution" function for the "Use Serial Number" case are not in the correct order (it does not match with the order of the elements given by the ps4000aAPI header). The "resolution" parameter shall be the last one, and in the example, it is the first one of the inputs. I hope this can help you to solve this issue. :D

Now, I will explain my problem.

I am trying to obtain a measurement of a 5V from a DC source. For that, I am using a +-5V range, so the readings shall be saturated, or at least, near the point of saturation. That is, the obtained value must be near 32727 (because of the 16-ADC counts).

However, I obtain a reading of 1310, which means around 0.2V! Could you please help me find out what is the problem in my readings?

I am using the PicoConnect 442 differential probe, and in the PicoScope6 software I obtain the correct 5V reading. Trigger and AutoStop are not enabled in the LabVIEW design.

Thank you in advance! :D

Martyn
Pico Staff Member
Pico Staff Member
Posts: 256
Joined: Thu Aug 11, 2011 7:43 am
Location: Cambridgeshire

Re: PicoScope 4444 streaming example in LabVIEW

Post by Martyn » Fri Jan 12, 2018 5:02 pm

You will receive better assistance by posting on the Test and Measurement Forum or by emailing support@picotech.com
Martyn
Technical Support Manager

Post Reply