Vehicle details: Audi S3
Engine code: AMK
Year: 2001
Symptom: P0102,
Author: Andy Cape | Cape Auto Diagnostics, Cape Town

Audi S3 | Rough idle

The problem

In July of 2010, a 2001 Audi S3 came to us with idling problems. To our disadvantage, a garage had previously worked on the vehicle and cleared the ‘DTC’ (Diagnostic Trouble Code) information from the ECU. The garage had also replaced the exhaust gas temperature sensor because a DTC for the sensor had been found. The other faults were ignored and erased. The client did not get a DTC report and we could not gather any other useful information.

The diagnosis

Initially we were looking for a vacuum leak, but we could not find one. We checked the MAF sensor with the automotive oscilloscope and software from Pico Technology, and found that the signal was not stable at idle. The MAF signal changed periodically and swings between 1.3 V  and 1.8 V, and cleaning of the MAF sensor did not help to improve the signal. Only when we disconnected the MAF sensor did the engine idle much better — almost like normal. We concluded that there were three possible causes of the signal fluctuation. Either the MAF sensor was defective, unmetered air was entering the system, or there was a defect in the turbo charger vacuum system.

The investigation

After a thorough investigation neither an air leak nor a vacuum leak could be found. We believed this only left the MAF sensor as being at fault, so recommended to the client that a replacement MAF sensor be purchased and fitted. However the client decided to leave the current MAF sensor disconnected, and re–connect it at a later date.

In May of 2011 the client came back to us, complaining the car was very heavy on fuel. We soon realized he had left the MAF sensor plug disconnected! The challenge now was to find the root cause of the problem, or to prove that the MAF was indeed faulty — without having a replacement part to hand.

Blue: MAF Red: Injectors #1

The initial test from July 2010 shows a MAF sensor signal periodically swinging from 1.3 V  (bottom) to 1.8 V  (top). The engine idle speed and injector timing are responding to the MAF sensor signal. The engine speed swings from 550 RPM to 1100 RPM and almost cuts out. A MAF signal of 1.3 V  at idle would be normal.

We now looked in more detail at the initial scope test from July to get a better idea. Another possible explanation could be that the engine RPM increased first, and then the MAF signal followed with a higher airflow, but what is causing the periodic damped swing?

Enlarged: Damped swing over 1 second, repeated periodically every few seconds

To our amazement we could not repeat the MAF signal swing any more. At times it looked normal, at 1.3 V  for the first half second in the above trace — but the engine cut out after a few seconds idling. Sometimes it looked like the signal below.

Swinging signal with noise

As soon we connected the MAF sensor plug, the engine cut out at idle immediately. We still assumed a vacuum leak at this time but could not find one.

DTC scan

The ECU was scanned and a few DTCs were found:

16486 - Mass Air Flow Sensor (G70): Signal too Low
P0102 - 35-10 - - - Intermittent

17522 - Oxygen (Lambda) Sensor; B1 S2: Internal Resistance too High
P1114 - 35-00 - -

17545 - Fuel Trim: Bank 1 (Add): System too Rich
P1137 - 35-00 - -

17704 - Error in Mapped Cooling System (check Temp-Sensor and Thermostat)
P1296 - 35-10 - - - Intermittent

16517 - Oxygen (Lambda) Sensor B1 S1: Response too Slow
P0133 - 35-10 - - - Intermittent

We know that the DTC P0102 is caused by the MAF being disconnected, so we can ignore this DTC. DTC P1137 points to a vacuum leak at idle, because the “(Add)” at fuel trim means additive trim, which is addressing an imbalance at idle. When the ECU is using additive trim, it is telling the injectors to stay open a fixed amount longer or shorter. The malfunction (e.g. vacuum leak) becomes less significant as RPM increase. For additive adaptation values, the injection timing is changed by a fixed amount. This value is not dependent on the basic injection timing, so we still are looking for the vacuum leak.

The vacuum was measured at idle with -0.6…-0.65 bar  (stable — no jumps) and only dropped to zero when the engine cut out. From previous experience: a vacuum leak inside the air inlet system produces a fluctuating or jumping measurement — corresponding to the hunting engine idle speed — but our reading was stable and the engine cut out after a few seconds.

The DTC P0133 reported a sluggish O2 sensor which can fail by exposure to a rich mixture over a long time (carbon fouling from rich mixture). The O2 sensor was tested and was working — however the cycling rate was too low.

The solution

The vacuum “leak” was found as we sprayed Engine Start–up Spray in the air intake and the idle speed did not increase at all! We could hold our hand in front of the MAF sensor and there was no suction to feel (normally the engine dies when you do this at idle). The suction duct (rubber elbow) was found to be completely off from the turbo charger, explaining the reason for the engine cutting out when the “defective” MAF sensor is connected. This hose connection is located deep down at the turbo charger and hard to get to. The broken connection was fixed temporarily and the engine idled smooth, with the previously thought to be “defective” MAF sensor connected and which did not cut out, proving the MAF sensor was actually working correctly.

The conclusion

First: We gained two examples of MAF scope waveforms which indicate the presence of an air leak. It will help us in the future for diagnostics when DTCs are not present.

Second: To save maintenance on an expensive car is never a good thing. The rubber hose broke because an engine oil leak (leaking oil from the turbo charger supply) had not been fixed. Driving the car without MAF sensor connected over a long period of time resulted in a damaged O2 sensor. While a new MAF sensor was not necessary (and a wrong diagnosis had initially been made) it had helped to find the root cause much quicker, without damaging the O2 sensor.

Download the PicoScope data files of the waveforms featured in this article:

psdata A3-AMK-turbo-air-mass-injector-wave1.psdata 1 MB
psdata A3-AMK-turbo-air-mass-injector-wave2.psdata 1 MB


12 comments | Add comment

Zander Boshoff
November 16 2014

The exact same thing just happened now with my s3. I was on the way to go buy a new maf and i thought lemme just turn it on to see if it sucks. No vacuum at all. It was the same pipe that was just off so thank you for this.

john kemp
October 10 2011

what company do you work for and were is it base need my s3 looking at and i think you know alot of what your talking about smile

Mohammed .S.Saleh
July 25 2011

The best way to keep your car in good condition follow what is car booklet tell.
In this way you save your money and your time

July 08 2011

Hi Andy
If this is 5 hfm bosch sensor do you want a quick and dirty 5 second test?

I assume when you were looking for a vacuum leak the smoke tester pressurised the plastic and it closed over the leak?


David Chiffens
June 23 2011

I would think you could here a leak that large.But yes If fuel trims were high I would smoke or propane it first.But it cant hurt to add another waveform to the database.

June 20 2011

I tend to agree, basic checks first, common failures second [S3 intake, boost piping failure] then bring out the scope. Nice to see another thorough technician in Cape Town. Good work

June 18 2011

so the lesson is.. basic checks first?

June 18 2011

So if the maf was seeing no airflow how did it have a voltage of 1.3 volts at idle ?

David Mollenue
June 18 2011

Sounds like you need to invest in a Smoke Meter - “we sprayed engine start up spray” - could it get any more unprofessional !

Nabil Chouchany (Billy)
June 18 2011

A good rounded up conclusion (including O2 sensor info etc…).
But i would have swapped the MAF for testing purposes, and confirmed the problem quicker….
However, it is very nice to get oscilloscope patterns that identify the faults…..keep up the good work!

Andy Cape
June 18 2011

To the first “clever” comment from Mr. name-less: When the car came the first time in - the vacuum leak was very little. A cut some where in the rubber was working like a valve and produced the MAF sensor waveform. The start up spray test increased the idle speed and around the rubbers was obviously no air leak. I would say the lesson learned is: The scope waveform from the MAF can give us a hint that there must be a air leak. Please send us one of your investigation reports.


Dean Birch
June 18 2011

I am always amazed at people like you that spend hours and hours trying to derive any useful information from an oscilloscope. Cause and effect are always very difficult to choose between when using a scope and I bet that I could have found this fault using a smoke machine before you had even got your scope out and connected it to the car !

Your email address will not be published. Required fields are marked *

Case study: Rough idle